Results of 1 - 10 of about 238 for section (0.006 sec.)
- http --- HTTP モジュール群 — Python 3.14.8 ドキュメント 11245
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » The Python standard library » インターネットプロトコルとサポート » http --- HTTP モジュール群 テーマ 自動 ライト ダーク | http --- HTTP モジュール群 ¶ ソースコー
...可能な、サポートされている、 IANA に登録されたステータスコード は: コード 列挙名 詳細 100 CONTINUE HTTP Semantics RFC 9110 , Section 15.2.1 101 SWITCHING_PROTOCOLS HTTP Semantics RFC 9110 , Section 15.2.2 102 PROCESSING WebDAV RFC 2518 , Section 10.1 103...EARLY_HINTS An HTTP Status Code for Indicating Hints RFC 8297 200 OK HTTP Semantics RFC 9110 , Section 15.3.1 201 CREATED HTTP Semantics RFC 9110 , Section 15.3.2 202 ACCEPTED HTTP Semantics RFC 9110 , Section 15.3.3 203 NON_...AUTHORITATIVE_INFORMATION HTTP Semantics RFC 9110 , Section 15.3.4 204 NO_CONTENT HTTP Semantics RFC 9110 , Section 15.3.5 205 RESET_CONTENT HTTP Semantics RFC 9110 , Section 15.3.6... - https://man.mtool.work/python/3.14/library/http.html
- http --- HTTP モジュール群 — Python 3.14.8 ドキュメント 11245
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » The Python standard library » インターネットプロトコルとサポート » http --- HTTP モジュール群 テーマ 自動 ライト ダーク | http --- HTTP モジュール群 ¶ ソースコー
...可能な、サポートされている、 IANA に登録されたステータスコード は: コード 列挙名 詳細 100 CONTINUE HTTP Semantics RFC 9110 , Section 15.2.1 101 SWITCHING_PROTOCOLS HTTP Semantics RFC 9110 , Section 15.2.2 102 PROCESSING WebDAV RFC 2518 , Section 10.1 103...EARLY_HINTS An HTTP Status Code for Indicating Hints RFC 8297 200 OK HTTP Semantics RFC 9110 , Section 15.3.1 201 CREATED HTTP Semantics RFC 9110 , Section 15.3.2 202 ACCEPTED HTTP Semantics RFC 9110 , Section 15.3.3 203 NON_...AUTHORITATIVE_INFORMATION HTTP Semantics RFC 9110 , Section 15.3.4 204 NO_CONTENT HTTP Semantics RFC 9110 , Section 15.3.5 205 RESET_CONTENT HTTP Semantics RFC 9110 , Section 15.3.6... - https://man.mtool.work/python/3.14/library/http.html
- configparser --- 設定ファイルのパーサー — Python 3.14.8 ドキュメント 10236
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » The Python standard library » ファイルフォーマット » configparser --- 設定ファイルのパーサー テーマ 自動 ライト ダーク | configparser --- 設定ファイルのパーサー
...User = hg [topsecret.server.example] Port = 50022 ForwardX11 = no The structure of INI files is described in the following section . Essentially, the file consists of sections, each of which contains keys with values. configparser classes can read and w...した。次はこれを読み込み直して、中のデータを取り出してみましょう。 >>> config = configparser . ConfigParser () >>> config . sections () [] >>> config . read ( 'example.ini' ) ['example.ini'] >>> config . sections () ['forge.example', 'topsecret.server.ex...。独自のコンバーターの登録、提供されたメソッドのカスタマイズもできます。 [ 1 ] 代替値 ¶ As with a dictionary, you can use a section's get() method to provide fallback values: >>> topsecret . get ( 'Port' ) '50022' >>> topsecret . get ( 'CompressionLevel'... - https://man.mtool.work/python/3.14/library/configparser.html
- configparser --- 設定ファイルのパーサー — Python 3.14.8 ドキュメント 10236
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » The Python standard library » ファイルフォーマット » configparser --- 設定ファイルのパーサー テーマ 自動 ライト ダーク | configparser --- 設定ファイルのパーサー
...User = hg [topsecret.server.example] Port = 50022 ForwardX11 = no The structure of INI files is described in the following section . Essentially, the file consists of sections, each of which contains keys with values. configparser classes can read and w...した。次はこれを読み込み直して、中のデータを取り出してみましょう。 >>> config = configparser . ConfigParser () >>> config . sections () [] >>> config . read ( 'example.ini' ) ['example.ini'] >>> config . sections () ['forge.example', 'topsecret.server.ex...。独自のコンバーターの登録、提供されたメソッドのカスタマイズもできます。 [ 1 ] 代替値 ¶ As with a dictionary, you can use a section's get() method to provide fallback values: >>> topsecret . get ( 'Port' ) '50022' >>> topsecret . get ( 'CompressionLevel'... - https://man.mtool.work/python/3.14/library/configparser.html
- Remote debugging attachment protocol — Python 3.14.8 ドキュメント 9381
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » Python HOWTO » Remote debugging attachment protocol テーマ 自動 ライト ダーク | Remote debugging attachment protocol ¶ This protocol enables external tools to at
...needed. Click Apply , then OK to confirm. 注釈 Ensure you've satisfied all Permission requirements before proceeding. This section describes the low-level protocol that enables external tools to inject and execute a Python script within a running CPytho...the basis of the sys.remote_exec() function, which instructs a remote Python process to execute a .py file. However, this section does not document the usage of that function. Instead, it provides a detailed explanation of the underlying protocol, whic...es remote execution capabilities without modifying the behavior or structure of the running Python application. Subsequent sections provide a step-by-step description of the protocol, including techniques for locating interpreter structures in memory, s... - https://man.mtool.work/python/3.14/howto/remote_debugging.html
- Remote debugging attachment protocol — Python 3.14.8 ドキュメント 9381
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » Python HOWTO » Remote debugging attachment protocol テーマ 自動 ライト ダーク | Remote debugging attachment protocol ¶ This protocol enables external tools to at
...needed. Click Apply , then OK to confirm. 注釈 Ensure you've satisfied all Permission requirements before proceeding. This section describes the low-level protocol that enables external tools to inject and execute a Python script within a running CPytho...the basis of the sys.remote_exec() function, which instructs a remote Python process to execute a .py file. However, this section does not document the usage of that function. Instead, it provides a detailed explanation of the underlying protocol, whic...es remote execution capabilities without modifying the behavior or structure of the running Python application. Subsequent sections provide a step-by-step description of the protocol, including techniques for locating interpreter structures in memory, s... - https://man.mtool.work/python/3.14/howto/remote_debugging.html
- 同期プリミティブ — Python 3.14.8 ドキュメント 9197
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » Python/C API reference manual » 同期プリミティブ テーマ 自動 ライト ダーク | 同期プリミティブ ¶ The C-API provides a basic mutual exclusion lock. type PyMutex ¶
...rrency control decisions, as the lock state may change immediately after the check. Added in version 3.14. Python critical section API ¶ The critical section API provides a deadlock avoidance layer on top of per-object locks for free-threaded CPython. T...reliance on the global interpreter lock , and are no-ops in versions of Python with the global interpreter lock. Critical sections are intended to be used for custom types implemented in C-API extensions. They should generally not be used with built-in...types like list and dict because their public C-APIs already use critical sections internally, with the notable exception of PyDict_Next() , which requires critical section to be acquired externally. Crit... - https://man.mtool.work/python/3.14/c-api/synchronization.html
- 同期プリミティブ — Python 3.14.8 ドキュメント 9157
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » Python/C API reference manual » 同期プリミティブ テーマ 自動 ライト ダーク | 同期プリミティブ ¶ The C-API provides a basic mutual exclusion lock. type PyMutex ¶
...rrency control decisions, as the lock state may change immediately after the check. Added in version 3.14. Python critical section API ¶ The critical section API provides a deadlock avoidance layer on top of per-object locks for free-threaded CPython. T...reliance on the global interpreter lock , and are no-ops in versions of Python with the global interpreter lock. Critical sections are intended to be used for custom types implemented in C-API extensions. They should generally not be used with built-in...types like list and dict because their public C-APIs already use critical sections internally, with the notable exception of PyDict_Next() , which requires critical section to be acquired externally. Crit... - https://man.mtool.work/python/3.14/c-api/synchronization.html
- C API Extension Support for Free Threading — Python 3.14.8 ドキュメント 8627
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » Python HOWTO » C API Extension Support for Free Threading テーマ 自動 ライト ダーク | C API Extension Support for Free Threading ¶ Starting with the 3.13 release
...unctions that return borrowed references may not be thread-safe if the containing object is modified concurrently. See the section on borrowed references for more information. Container Thread Safety ¶ Containers like PyListObject , PyDictObject , and P...PyDict_Next ¶ A notable exception is PyDict_Next() , which does not lock the dictionary. You should use Py_BEGIN_CRITICAL_SECTION to protect the dictionary while iterating over it if the dictionary may be concurrently modified: Py_BEGIN_CRITICAL_SECTIO...ect * key , * value ; Py_ssize_t pos = 0 ; while ( PyDict_Next ( dict , & pos , & key , & value )) { ... } Py_END_CRITICAL_SECTION (); Borrowed References ¶ Some C API functions return borrowed references . These APIs are not thread-safe if the containi... - https://man.mtool.work/python/3.14/howto/free-threading-extensions.html
- C API Extension Support for Free Threading — Python 3.14.8 ドキュメント 8627
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » Python HOWTO » C API Extension Support for Free Threading テーマ 自動 ライト ダーク | C API Extension Support for Free Threading ¶ Starting with the 3.13 release
...unctions that return borrowed references may not be thread-safe if the containing object is modified concurrently. See the section on borrowed references for more information. Container Thread Safety ¶ Containers like PyListObject , PyDictObject , and P...PyDict_Next ¶ A notable exception is PyDict_Next() , which does not lock the dictionary. You should use Py_BEGIN_CRITICAL_SECTION to protect the dictionary while iterating over it if the dictionary may be concurrently modified: Py_BEGIN_CRITICAL_SECTIO...ect * key , * value ; Py_ssize_t pos = 0 ; while ( PyDict_Next ( dict , & pos , & key , & value )) { ... } Py_END_CRITICAL_SECTION (); Borrowed References ¶ Some C API functions return borrowed references . These APIs are not thread-safe if the containi... - https://man.mtool.work/python/3.14/howto/free-threading-extensions.html