Results of 1 - 10 of about 168 for encoded (0.003 sec.)
- email.headerregistry: Custom Header Objects — Python 3.14.8 ドキュメント 9881
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » The Python standard library » インターネット上のデータの操作 » email --- 電子メールと MIME 処理のためのパッケージ » email.headerregistry : Custom Header Objects
...o the parse tree obtained from parsing the header. The parse method should assume that string may contain content-transfer-encoded parts, but should correctly handle all valid Unicode characters as well so that it can parse un-encoded header values. その...C 5322 compatible mechanism for encoding non-ASCII text as ASCII characters within a header value. When a value containing encoded words is passed to the constructor, the UnstructuredHeader parser converts such encoded words into a string, following the...RFC 2047 rules for unstructured text. The parser uses heuristics to attempt to decode certain non-compliant encoded words. Defects are registered in such cases, as well as defects for issues such as invalid characters within the encoded w... - https://man.mtool.work/python/3.14/library/email.headerregistry.html
- email.headerregistry: Custom Header Objects — Python 3.14.8 ドキュメント 9881
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » The Python standard library » インターネット上のデータの操作 » email --- 電子メールと MIME 処理のためのパッケージ » email.headerregistry : Custom Header Objects
...o the parse tree obtained from parsing the header. The parse method should assume that string may contain content-transfer-encoded parts, but should correctly handle all valid Unicode characters as well so that it can parse un-encoded header values. その...C 5322 compatible mechanism for encoding non-ASCII text as ASCII characters within a header value. When a value containing encoded words is passed to the constructor, the UnstructuredHeader parser converts such encoded words into a string, following the...RFC 2047 rules for unstructured text. The parser uses heuristics to attempt to decode certain non-compliant encoded words. Defects are registered in such cases, as well as defects for issues such as invalid characters within the encoded w... - https://man.mtool.work/python/3.14/library/email.headerregistry.html
- base64 --- Base16, Base32, Base64, Base85 データのエンコード — Python 3.14.8 ド... 9756
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » The Python standard library » インターネット上のデータの操作 » base64 --- Base16, Base32, Base64, Base85 データのエンコード テーマ 自動 ライト ダーク | base64 --
...esystem-safe alphabet, which substitutes - instead of + and _ instead of / in the standard Base64 alphabet, and return the encoded bytes . The result can still contain = . base64. urlsafe_b64decode ( s ) ¶ bytes-like object または ASCII 文字列 s を URLと...not part of the standard encoding used in PDF, as it does not preserve the length of the data. adobe controls whether the encoded byte sequence is framed with <~ and ~> , as in a PostScript base-85 string literal. Note that while ASCII85Decode streams...the length of the data may not be preserved on decoding. Added in version 3.4. base64. b85decode ( b ) ¶ Decode the base85-encoded bytes-like object or ASCII string b and return the decoded bytes . Added in version 3.4. base64. z85encode ( s ) ¶ Encode... - https://man.mtool.work/python/3.14/library/base64.html
- base64 --- Base16, Base32, Base64, Base85 データのエンコード — Python 3.14.8 ド... 9756
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » The Python standard library » インターネット上のデータの操作 » base64 --- Base16, Base32, Base64, Base85 データのエンコード テーマ 自動 ライト ダーク | base64 --
...esystem-safe alphabet, which substitutes - instead of + and _ instead of / in the standard Base64 alphabet, and return the encoded bytes . The result can still contain = . base64. urlsafe_b64decode ( s ) ¶ bytes-like object または ASCII 文字列 s を URLと...not part of the standard encoding used in PDF, as it does not preserve the length of the data. adobe controls whether the encoded byte sequence is framed with <~ and ~> , as in a PostScript base-85 string literal. Note that while ASCII85Decode streams...the length of the data may not be preserved on decoding. Added in version 3.4. base64. b85decode ( b ) ¶ Decode the base85-encoded bytes-like object or ASCII string b and return the decoded bytes . Added in version 3.4. base64. z85encode ( s ) ¶ Encode... - https://man.mtool.work/python/3.14/library/base64.html
- マップ型プロトコル (mapping protocol) — Python 3.14.8 ドキュメント 9643
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » Python/C API reference manual » 抽象オブジェクトレイヤ (Abstract Objects Layer) » マップ型プロトコル (mapping protocol) テーマ 自動 ライト ダーク | マップ型プロト
...しい参照。 次に属します: Stable ABI . This is the same as PyObject_GetItem() , but key is specified as a const char * UTF-8 encoded bytes string, rather than a PyObject * . int PyMapping_GetOptionalItem ( PyObject * obj , PyObject * key , PyObject * * re...ABI (バージョン 3.13 より). This is the same as PyMapping_GetOptionalItem() , but key is specified as a const char * UTF-8 encoded bytes string, rather than a PyObject * . Added in version 3.13. int PyMapping_SetItemString ( PyObject * o , const char *...t * v ) ¶ 次に属します: Stable ABI . This is the same as PyObject_SetItem() , but key is specified as a const char * UTF-8 encoded bytes string, rather than a PyObject * . int PyMapping_DelItem ( PyObject * o , PyObject * key ) ¶ This is an alias of PyO... - https://man.mtool.work/python/3.14/c-api/mapping.html
- マップ型プロトコル (mapping protocol) — Python 3.14.8 ドキュメント 9643
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » Python/C API reference manual » 抽象オブジェクトレイヤ (Abstract Objects Layer) » マップ型プロトコル (mapping protocol) テーマ 自動 ライト ダーク | マップ型プロト
...しい参照。 次に属します: Stable ABI . This is the same as PyObject_GetItem() , but key is specified as a const char * UTF-8 encoded bytes string, rather than a PyObject * . int PyMapping_GetOptionalItem ( PyObject * obj , PyObject * key , PyObject * * re...ABI (バージョン 3.13 より). This is the same as PyMapping_GetOptionalItem() , but key is specified as a const char * UTF-8 encoded bytes string, rather than a PyObject * . Added in version 3.13. int PyMapping_SetItemString ( PyObject * o , const char *...t * v ) ¶ 次に属します: Stable ABI . This is the same as PyObject_SetItem() , but key is specified as a const char * UTF-8 encoded bytes string, rather than a PyObject * . int PyMapping_DelItem ( PyObject * o , PyObject * key ) ¶ This is an alias of PyO... - https://man.mtool.work/python/3.14/c-api/mapping.html
- API と ABI のバージョニング — Python 3.14.8 ドキュメント 8930
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » Python/C API reference manual » API と ABI のバージョニング テーマ 自動 ライト ダーク | API と ABI のバージョニング ¶ Build-time version constants ¶ CPython expo
...となります。 PY_RELEASE_SERIAL ¶ 3.4.1a2 の 2 。最終リリースでは 0 になります。 PY_VERSION_HEX ¶ The Python version number encoded in a single integer. See Py_PACK_FULL_VERSION() for the encoding details. Use this for numeric comparisons, for example, #...sion ¶ const unsigned long Py_Version ¶ 次に属します: Stable ABI (バージョン 3.11 より). The Python runtime version number encoded in a single constant integer. See Py_PACK_FULL_VERSION() for the encoding details. This contains the Python version used a...ro , int release_level , int release_serial ) ¶ 次に属します: Stable ABI (バージョン 3.14 より). Return the given version, encoded as a single 32-bit integer with the following structure: Argument No. of bits Bit mask Bit shift Example values 3.4.1a2 3.... - https://man.mtool.work/python/3.14/c-api/apiabiversion.html
- API と ABI のバージョニング — Python 3.14.8 ドキュメント 8930
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » Python/C API reference manual » API と ABI のバージョニング テーマ 自動 ライト ダーク | API と ABI のバージョニング ¶ Build-time version constants ¶ CPython expo
...となります。 PY_RELEASE_SERIAL ¶ 3.4.1a2 の 2 。最終リリースでは 0 になります。 PY_VERSION_HEX ¶ The Python version number encoded in a single integer. See Py_PACK_FULL_VERSION() for the encoding details. Use this for numeric comparisons, for example, #...sion ¶ const unsigned long Py_Version ¶ 次に属します: Stable ABI (バージョン 3.11 より). The Python runtime version number encoded in a single constant integer. See Py_PACK_FULL_VERSION() for the encoding details. This contains the Python version used a...ro , int release_level , int release_serial ) ¶ 次に属します: Stable ABI (バージョン 3.14 より). Return the given version, encoded as a single 32-bit integer with the following structure: Argument No. of bits Bit mask Bit shift Example values 3.4.1a2 3.... - https://man.mtool.work/python/3.14/c-api/apiabiversion.html
- email.errors: Exception and Defect classes — Python 3.14.8 ドキュメント 8568
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » The Python standard library » インターネット上のデータの操作 » email --- 電子メールと MIME 処理のためのパッケージ » email.errors : Exception and Defect classes テ
...content type claims to be multipart . exception email.errors. InvalidBase64PaddingDefect ¶ When decoding a block of base64 encoded bytes, the padding was not correct. Enough padding is added to perform the decode, but the resulting decoded bytes may be...invalid. exception email.errors. InvalidBase64CharactersDefect ¶ When decoding a block of base64 encoded bytes, characters outside the base64 alphabet were encountered. The characters are ignored, but the resulting decoded byte...s may be invalid. exception email.errors. InvalidBase64LengthDefect ¶ When decoding a block of base64 encoded bytes, the number of non-padding base64 characters was invalid (1 more than a multiple of 4). The encoded block was kept a... - https://man.mtool.work/python/3.14/library/email.errors.html
- email.policy: Policy Objects — Python 3.14.8 ドキュメント 8330
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » The Python standard library » インターネット上のデータの操作 » email --- 電子メールと MIME 処理のためのパッケージ » email.policy : Policy Objects テーマ 自動 ライ
...d. The possible values are: 7bit all data must be "7 bit clean" (ASCII-only). This means that where necessary data will be encoded using either quoted-printable or base64 encoding. 8bit data is not constrained to be 7 bit clean. Data in headers is still...required to be ASCII-only and so will be encoded (see fold_binary() and utf8 below for exceptions), but body parts may use the 8bit CTE. A cte_type value of 8bit only work...in version 3.6: [ 1 ] utf8 ¶ If False , follow RFC 5322 , supporting non-ASCII characters in headers by encoding them as "encoded words". If True , follow RFC 6532 and use utf-8 encoding for headers. Messages formatted in this way may be passed to SMTP... - https://man.mtool.work/python/3.14/library/email.policy.html