Results of 1 - 10 of about 54 for component (0.008 sec.)
- email --- 電子メールと MIME 処理のためのパッケージ — Python 3.14.8 ドキュメント 12445
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » The Python standard library » インターネット上のデータの操作 » email --- 電子メールと MIME 処理のためのパッケージ テーマ 自動 ライト ダーク | email --- 電子メール
...RFC 2046 , RFC 2047 , RFC 2183 , and RFC 2231 . The overall structure of the email package can be divided into three major components, plus a fourth component that controls the behavior of the other components. The central component of the package is an "...lication can use this API to ask questions about an existing email, to construct a new email, or to add or remove email subcomponents that themselves use the same object model interface. That is, following the nature of email messages and their MIME subco...mponents, the email object model is a tree structure of objects that all provide the EmailMessage API. The other two major components of the package are the parser and the generator . The parser takes the serialized version of an email message (a stream o... - https://man.mtool.work/python/3.14/library/email.html
- email --- 電子メールと MIME 処理のためのパッケージ — Python 3.14.8 ドキュメント 10784
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » The Python standard library » インターネット上のデータの操作 » email --- 電子メールと MIME 処理のためのパッケージ テーマ 自動 ライト ダーク | email --- 電子メール
...RFC 2046 , RFC 2047 , RFC 2183 , and RFC 2231 . The overall structure of the email package can be divided into three major components, plus a fourth component that controls the behavior of the other components. The central component of the package is an "...lication can use this API to ask questions about an existing email, to construct a new email, or to add or remove email subcomponents that themselves use the same object model interface. That is, following the nature of email messages and their MIME subco...mponents, the email object model is a tree structure of objects that all provide the EmailMessage API. The other two major components of the package are the parser and the generator . The parser takes the serialized version of an email message (a stream o... - https://man.mtool.work/python/3.14/library/email.html
- urllib.parse --- URL を構成要素に解析する — Python 3.14.8 ドキュメント 10784
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » The Python standard library » インターネットプロトコルとサポート » urllib.parse --- URL を構成要素に解析する テーマ 自動 ライト ダーク | urllib.parse --- URL を構
...文字列を生成します。 urllib.parse. urlsplit ( urlstring , scheme = None , allow_fragments = True ) ¶ Parse a URL into five components, returning a 5-item named tuple SplitResult or SplitResultBytes . This corresponds to the general structure of a URL: sch...a string, possibly empty. The delimiters as shown above are not part of the result, except for a leading slash in the path component, which is retained if present. Additionally, the netloc property is broken down into these additional attributes added to...y if it is properly introduced by '//'. Otherwise the input is presumed to be a relative URL and thus to start with a path component. >>> from urllib.parse import urlsplit >>> urlsplit ( '//www.cwi.nl:80/ %7E guido/Python.html' ) SplitResult(scheme='', ne... - https://man.mtool.work/python/3.14/library/urllib.parse.html
- urllib.parse --- URL を構成要素に解析する — Python 3.14.8 ドキュメント 10784
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » The Python standard library » インターネットプロトコルとサポート » urllib.parse --- URL を構成要素に解析する テーマ 自動 ライト ダーク | urllib.parse --- URL を構
...文字列を生成します。 urllib.parse. urlsplit ( urlstring , scheme = None , allow_fragments = True ) ¶ Parse a URL into five components, returning a 5-item named tuple SplitResult or SplitResultBytes . This corresponds to the general structure of a URL: sch...a string, possibly empty. The delimiters as shown above are not part of the result, except for a leading slash in the path component, which is retained if present. Additionally, the netloc property is broken down into these additional attributes added to...y if it is properly introduced by '//'. Otherwise the input is presumed to be a relative URL and thus to start with a path component. >>> from urllib.parse import urlsplit >>> urlsplit ( '//www.cwi.nl:80/ %7E guido/Python.html' ) SplitResult(scheme='', ne... - https://man.mtool.work/python/3.14/library/urllib.parse.html
- os.path --- 一般的なパス名操作 — Python 3.14.8 ドキュメント 9953
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » The Python standard library » ファイルとディレクトリへのアクセス » os.path --- 一般的なパス名操作 テーマ 自動 ライト ダーク | os.path --- 一般的なパス名操作 ¶ ソ
...wise a combination of HOMEPATH and HOMEDRIVE will be used. An initial ~user is handled by checking that the last directory component of the current user's home directory matches USERNAME , and replacing it if so. 置き換えに失敗したり、引数のパスがチルダで...nce with IEEE Std 1003.1 2013 Edition; 4.13 Pathname Resolution , if a pathname begins with exactly two slashes, the first component following the leading characters may be interpreted in an implementation-defined manner, although more than two leading ch...r from the case of path , in particular the drive letter is capitalized. By default, the path is evaluated up to the first component that does not exist, is a symlink loop, or whose evaluation raises OSError . All such components are appended unchanged to... - https://man.mtool.work/python/3.14/library/os.path.html
- os.path --- 一般的なパス名操作 — Python 3.14.8 ドキュメント 9953
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » The Python standard library » ファイルとディレクトリへのアクセス » os.path --- 一般的なパス名操作 テーマ 自動 ライト ダーク | os.path --- 一般的なパス名操作 ¶ ソ
...wise a combination of HOMEPATH and HOMEDRIVE will be used. An initial ~user is handled by checking that the last directory component of the current user's home directory matches USERNAME , and replacing it if so. 置き換えに失敗したり、引数のパスがチルダで...nce with IEEE Std 1003.1 2013 Edition; 4.13 Pathname Resolution , if a pathname begins with exactly two slashes, the first component following the leading characters may be interpreted in an implementation-defined manner, although more than two leading ch...r from the case of path , in particular the drive letter is capitalized. By default, the path is evaluated up to the first component that does not exist, is a symlink loop, or whose evaluation raises OSError . All such components are appended unchanged to... - https://man.mtool.work/python/3.14/library/os.path.html
- デスクリプタ ガイド — Python 3.14.8 ドキュメント 9404
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » Python HOWTO » デスクリプタ ガイド テーマ 自動 ライト ダーク | デスクリプタ ガイド ¶ Author : Raymond Hettinger Contact : <python at rcn dot com> デスクリプタ を
...for { value !r} ' ) 実践的なアプリケーション ¶ 次のコードは実際のクラスでデータバリデータを使う方法のサンプルです。 class Component : name = String ( minsize = 3 , maxsize = 10 , predicate = str . isupper ) kind = OneOf ( 'wood' , 'metal' , 'plastic' ) q...name self . kind = kind self . quantity = quantity これらのデスクリプタは、不正インスタンスが作成されるのを防ぎます。 >>> Component ( 'Widget' , 'metal' , 5 ) # Blocked: 'Widget' is not all uppercase Traceback (most recent call last): ... ValueError : Ex...pected <method 'isupper' of 'str' objects> to be true for 'Widget' >>> Component ( 'WIDGET' , 'metle' , 5 ) # Blocked: 'metle' is misspelled Traceback (most recent call last): ... ValueError : Expected '... - https://man.mtool.work/python/3.14/howto/descriptor.html
- デスクリプタ ガイド — Python 3.14.8 ドキュメント 9404
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » Python HOWTO » デスクリプタ ガイド テーマ 自動 ライト ダーク | デスクリプタ ガイド ¶ Author : Raymond Hettinger Contact : <python at rcn dot com> デスクリプタ を
...for { value !r} ' ) 実践的なアプリケーション ¶ 次のコードは実際のクラスでデータバリデータを使う方法のサンプルです。 class Component : name = String ( minsize = 3 , maxsize = 10 , predicate = str . isupper ) kind = OneOf ( 'wood' , 'metal' , 'plastic' ) q...name self . kind = kind self . quantity = quantity これらのデスクリプタは、不正インスタンスが作成されるのを防ぎます。 >>> Component ( 'Widget' , 'metal' , 5 ) # Blocked: 'Widget' is not all uppercase Traceback (most recent call last): ... ValueError : Ex...pected <method 'isupper' of 'str' objects> to be true for 'Widget' >>> Component ( 'WIDGET' , 'metle' , 5 ) # Blocked: 'metle' is misspelled Traceback (most recent call last): ... ValueError : Expected '... - https://man.mtool.work/python/3.14/howto/descriptor.html
- copy --- 浅いコピーおよび深いコピー操作 — Python 3.14.8 ドキュメント 8855
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » The Python standard library » データ型 » copy --- 浅いコピーおよび深いコピー操作 テーマ 自動 ライト ダーク | copy --- 浅いコピーおよび深いコピー操作 ¶ ソースコー
...eration; it is passed one argument, the memo dictionary. If the __deepcopy__ implementation needs to make a deep copy of a component, it should call the deepcopy() function with the component as first argument and the memo dictionary as second argument. T... - https://man.mtool.work/python/3.14/library/copy.html
- copy --- 浅いコピーおよび深いコピー操作 — Python 3.14.8 ドキュメント 8855
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » The Python standard library » データ型 » copy --- 浅いコピーおよび深いコピー操作 テーマ 自動 ライト ダーク | copy --- 浅いコピーおよび深いコピー操作 ¶ ソースコー
...eration; it is passed one argument, the memo dictionary. If the __deepcopy__ implementation needs to make a deep copy of a component, it should call the deepcopy() function with the component as first argument and the memo dictionary as second argument. T... - https://man.mtool.work/python/3.14/library/copy.html