per page, with , order by , clip by
Results of 1 - 10 of about 76 for charset (0.009 sec.)
email.charset: 文字集合の表現 — Python 3.14.8 ドキュメント 12717
ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » The Python standard library » インターネット上のデータの操作 » email --- 電子メールと MIME 処理のためのパッケージ » email.charset : 文字集合の表現 テーマ 自動 ラ ... イト ダーク | email.charset : 文字集合の表現 ¶ ソースコード: Lib/email/charset.py このモジュールは、レガシーな ( Compat32 ) email API の一部分です。 新 ... キストはモジュールの元々のドキュメントです。 このモジュールは文字集合の表現および電子メールメッセージの文字集合の変換を行う Charset クラスに加え、文字集合のレジストリとそれを操作する簡易メソッドを提供しています。 Charset インスタンスは email パッケージ中 ... にある他のいくつかのモジュールで使用されます。 Import this class from the email.charset module. class email.charset. Charset ( input_charset = DEFAULT_CHARSET ) ¶ 文字集合を電子メールのプロパティに写像します。 ...
https://man.mtool.work/python/3.14/library/email.charset.html
email.charset: 文字集合の表現 — Python 3.14.8 ドキュメント 12717
ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » The Python standard library » インターネット上のデータの操作 » email --- 電子メールと MIME 処理のためのパッケージ » email.charset : 文字集合の表現 テーマ 自動 ラ ... イト ダーク | email.charset : 文字集合の表現 ¶ ソースコード: Lib/email/charset.py このモジュールは、レガシーな ( Compat32 ) email API の一部分です。 新 ... キストはモジュールの元々のドキュメントです。 このモジュールは文字集合の表現および電子メールメッセージの文字集合の変換を行う Charset クラスに加え、文字集合のレジストリとそれを操作する簡易メソッドを提供しています。 Charset インスタンスは email パッケージ中 ... にある他のいくつかのモジュールで使用されます。 Import this class from the email.charset module. class email.charset. Charset ( input_charset = DEFAULT_CHARSET ) ¶ 文字集合を電子メールのプロパティに写像します。 ...
https://man.mtool.work/python/3.14/library/email.charset.html
email.message.Message: compat32 API を使用した電子メールメッセージの表現 — Pyth... 10805
ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » The Python standard library » インターネット上のデータの操作 » email --- 電子メールと MIME 処理のためのパッケージ » email.message.Message : compat32 API を使用し ... fer-Encoding . However, for a Content-Transfer-Encoding of 8bit, an attempt is made to decode the original bytes using the charset specified by the Content-Type header, using the replace error handler. If no charset is specified, or if the charset given ... is not recognized by the email package, the body is decoded using the default ASCII charset. This is a legacy method. On the EmailMessage class its functionality is replaced by get_content() and iter_parts() . set_ ... payload ( payload , charset = None ) ¶ メッセージオブジェクト全体のペイロードを payload に設定します。クライアントはペイロードを変更してはいけません。 ...
https://man.mtool.work/python/3.14/library/email.compat32-message.html
email.message.Message: compat32 API を使用した電子メールメッセージの表現 — Pyth... 10805
ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » The Python standard library » インターネット上のデータの操作 » email --- 電子メールと MIME 処理のためのパッケージ » email.message.Message : compat32 API を使用し ... fer-Encoding . However, for a Content-Transfer-Encoding of 8bit, an attempt is made to decode the original bytes using the charset specified by the Content-Type header, using the replace error handler. If no charset is specified, or if the charset given ... is not recognized by the email package, the body is decoded using the default ASCII charset. This is a legacy method. On the EmailMessage class its functionality is replaced by get_content() and iter_parts() . set_ ... payload ( payload , charset = None ) ¶ メッセージオブジェクト全体のペイロードを payload に設定します。クライアントはペイロードを変更してはいけません。 ...
https://man.mtool.work/python/3.14/library/email.compat32-message.html
email.header: 国際化されたヘッダー — Python 3.14.8 ドキュメント 9946
ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » The Python standard library » インターネット上のデータの操作 » email --- 電子メールと MIME 処理のためのパッケージ » email.header : 国際化されたヘッダー テーマ 自 ... e RFC 2045 , RFC 2046 , RFC 2047 , and RFC 2231 . The email package supports these standards in its email.header and email.charset modules. If you want to include non-ASCII characters in your email headers, say in the Subject or To fields, you should us ... is header using the embedded ISO-8859-1 character. 以下は Header クラスの説明です: class email.header. Header ( s = None , charset = None , maxlinelen = None , header_name = None , continuation_ws = ' ' , errors = 'strict' ) ¶ 別の文字集合の文字列を含む ... は bytes または str のインスタンスにできます。このセマンティクスについては append() の項を参照してください。 オプション引数 charset には 2 つの目的があります。ひとつは append() メソッドにおける charset 引数と同じものです。もうひとつは、これ以降 charset 引 ...
https://man.mtool.work/python/3.14/library/email.header.html
email.header: 国際化されたヘッダー — Python 3.14.8 ドキュメント 9946
ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » The Python standard library » インターネット上のデータの操作 » email --- 電子メールと MIME 処理のためのパッケージ » email.header : 国際化されたヘッダー テーマ 自 ... e RFC 2045 , RFC 2046 , RFC 2047 , and RFC 2231 . The email package supports these standards in its email.header and email.charset modules. If you want to include non-ASCII characters in your email headers, say in the Subject or To fields, you should us ... is header using the embedded ISO-8859-1 character. 以下は Header クラスの説明です: class email.header. Header ( s = None , charset = None , maxlinelen = None , header_name = None , continuation_ws = ' ' , errors = 'strict' ) ¶ 別の文字集合の文字列を含む ... は bytes または str のインスタンスにできます。このセマンティクスについては append() の項を参照してください。 オプション引数 charset には 2 つの目的があります。ひとつは append() メソッドにおける charset 引数と同じものです。もうひとつは、これ以降 charset 引 ...
https://man.mtool.work/python/3.14/library/email.header.html
email.utils: Miscellaneous utilities — Python 3.14.8 ドキュメント 7979
ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » The Python standard library » インターネット上のデータの操作 » email --- 電子メールと MIME 処理のためのパッケージ » email.utils : Miscellaneous utilities テーマ ... ージョン 3.13 で変更: Add strict optional parameter and reject malformed inputs by default. email.utils. formataddr ( pair , charset = 'utf-8' ) ¶ parseaddr() の逆で、2 要素のタプル (realname, email_address) を取って To や Cc ヘッダに適した文字列を返します ... 。タプル pair の第1要素が偽である場合、第2要素の値をそのまま返します。 任意の charset は、 realname が非 ASCII 文字を含んでいる場合にその RFC 2047 エンコーディングに使われる文字集合です。 str か Charset のイン ... スタンスで、デフォルトは utf-8 です。 バージョン 3.3 で変更: charset オプションが追加されました。 email.utils. getaddresses ( fieldvalues , * , strict = True ) ¶ This method returns a list of ...
https://man.mtool.work/python/3.14/library/email.utils.html
email.utils: Miscellaneous utilities — Python 3.14.8 ドキュメント 7979
ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » The Python standard library » インターネット上のデータの操作 » email --- 電子メールと MIME 処理のためのパッケージ » email.utils : Miscellaneous utilities テーマ ... ージョン 3.13 で変更: Add strict optional parameter and reject malformed inputs by default. email.utils. formataddr ( pair , charset = 'utf-8' ) ¶ parseaddr() の逆で、2 要素のタプル (realname, email_address) を取って To や Cc ヘッダに適した文字列を返します ... 。タプル pair の第1要素が偽である場合、第2要素の値をそのまま返します。 任意の charset は、 realname が非 ASCII 文字を含んでいる場合にその RFC 2047 エンコーディングに使われる文字集合です。 str か Charset のイン ... スタンスで、デフォルトは utf-8 です。 バージョン 3.3 で変更: charset オプションが追加されました。 email.utils. getaddresses ( fieldvalues , * , strict = True ) ¶ This method returns a list of ...
https://man.mtool.work/python/3.14/library/email.utils.html
email.message: Representing an email message — Python 3.14.8 ドキュメント 7896
ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » The Python standard library » インターネット上のデータの操作 » email --- 電子メールと MIME 処理のためのパッケージ » email.message : Representing an email message ... alue" unless the value is None , in which case only the key will be added. If the value contains non-ASCII characters, the charset and language may be explicitly controlled by specifying the value as a three tuple in the format (CHARSET, LANGUAGE, VALUE ... ) , where CHARSET is a string naming the charset to be used to encode the value, LANGUAGE can usually be set to None or the empty string (se ... ee tuple is not passed and the value contains non-ASCII characters, it is automatically encoded in RFC 2231 format using a CHARSET of utf-8 and a LANGUAGE of None . 以下に例を示します。: msg . add_header ( 'Content-Disposition' , 'attachment' , filename ...
https://man.mtool.work/python/3.14/library/email.message.html
email.message: Representing an email message — Python 3.14.8 ドキュメント 7896
ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » The Python standard library » インターネット上のデータの操作 » email --- 電子メールと MIME 処理のためのパッケージ » email.message : Representing an email message ... alue" unless the value is None , in which case only the key will be added. If the value contains non-ASCII characters, the charset and language may be explicitly controlled by specifying the value as a three tuple in the format (CHARSET, LANGUAGE, VALUE ... ) , where CHARSET is a string naming the charset to be used to encode the value, LANGUAGE can usually be set to None or the empty string (se ... ee tuple is not passed and the value contains non-ASCII characters, it is automatically encoded in RFC 2231 format using a CHARSET of utf-8 and a LANGUAGE of None . 以下に例を示します。: msg . add_header ( 'Content-Disposition' , 'attachment' , filename ...
https://man.mtool.work/python/3.14/library/email.message.html
PREV 1 2 3 4 5 6 7 8 NEXT