Results of 1 - 10 of about 116 for algorithm (0.006 sec.)
- PyHash API — Python 3.14.8 ドキュメント 14470
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » Python/C API reference manual » ユーティリティ » PyHash API テーマ 自動 ライト ダーク | PyHash API ¶ PyTypeObject.tp_hash メンバや 数値型のハッシュ化 も参照してく
...シュ値型: 符号付き整数。 Added in version 3.2. type Py_uhash_t ¶ ハッシュ値型: 符号なし整数。 Added in version 3.2. Py_HASH_ALGORITHM ¶ str 、 bytes や memoryview のハッシュ用アルゴリズムを示す数値型。 アルゴリズム名は sys.hash_info.algorithm により公開され...ます。 Added in version 3.4. Py_HASH_FNV ¶ Py_HASH_SIPHASH24 ¶ Py_HASH_SIPHASH13 ¶ Numerical values to compare to Py_HASH_ALGORITHM to determine which algorithm is used for hashing. The hash algorithm can be configured via the configure --with-hash-algor...y_HASH_SIPHASH13 . Py_HASH_CUTOFF ¶ Buffers of length in range [1, Py_HASH_CUTOFF) are hashed using DJBX33A instead of the algorithm described by Py_HASH_ALGORITHM . A Py_HASH_CUTOFF of 0 disables the optimization. Py_HASH_CUTOFF must be non-negative and... - https://man.mtool.work/python/3.14/c-api/hash.html
- PyHash API — Python 3.14.8 ドキュメント 14470
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » Python/C API reference manual » ユーティリティ » PyHash API テーマ 自動 ライト ダーク | PyHash API ¶ PyTypeObject.tp_hash メンバや 数値型のハッシュ化 も参照してく
...シュ値型: 符号付き整数。 Added in version 3.2. type Py_uhash_t ¶ ハッシュ値型: 符号なし整数。 Added in version 3.2. Py_HASH_ALGORITHM ¶ str 、 bytes や memoryview のハッシュ用アルゴリズムを示す数値型。 アルゴリズム名は sys.hash_info.algorithm により公開され...ます。 Added in version 3.4. Py_HASH_FNV ¶ Py_HASH_SIPHASH24 ¶ Py_HASH_SIPHASH13 ¶ Numerical values to compare to Py_HASH_ALGORITHM to determine which algorithm is used for hashing. The hash algorithm can be configured via the configure --with-hash-algor...y_HASH_SIPHASH13 . Py_HASH_CUTOFF ¶ Buffers of length in range [1, Py_HASH_CUTOFF) are hashed using DJBX33A instead of the algorithm described by Py_HASH_ALGORITHM . A Py_HASH_CUTOFF of 0 disables the optimization. Py_HASH_CUTOFF must be non-negative and... - https://man.mtool.work/python/3.14/c-api/hash.html
- difflib --- 差分の計算の補助 — Python 3.14.8 ドキュメント 8819
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » The Python standard library » テキスト処理サービス » difflib --- 差分の計算の補助 テーマ 自動 ライト ダーク | difflib --- 差分の計算の補助 ¶ ソースコード: Lib/di
...and context and unified diffs -- formats produced by tools like diff and git diff . Comparisons are done using a matching algorithm implemented in SequenceMatcher -- a flexible class for comparing pairs of sequences of any type, not just text, so long as...arities. Ideally, these are uninteresting or common items, such as blank lines or whitespace. This heuristic can speed the algorithm up (because it reduces the number of possible combinations) and it can produce results that are more understandable for hu...unk argument to False ) or tuning it (using the isjunk argument, perhaps to one of the predefined functions ). The difflib algorithm ¶ The algorithm used in SequenceMatcher predates, and is a little fancier than, an algorithm published in the late 1980s b... - https://man.mtool.work/python/3.14/library/difflib.html
- difflib --- 差分の計算の補助 — Python 3.14.8 ドキュメント 8819
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » The Python standard library » テキスト処理サービス » difflib --- 差分の計算の補助 テーマ 自動 ライト ダーク | difflib --- 差分の計算の補助 ¶ ソースコード: Lib/di
...and context and unified diffs -- formats produced by tools like diff and git diff . Comparisons are done using a matching algorithm implemented in SequenceMatcher -- a flexible class for comparing pairs of sequences of any type, not just text, so long as...arities. Ideally, these are uninteresting or common items, such as blank lines or whitespace. This heuristic can speed the algorithm up (because it reduces the number of possible combinations) and it can produce results that are more understandable for hu...unk argument to False ) or tuning it (using the isjunk argument, perhaps to one of the predefined functions ). The difflib algorithm ¶ The algorithm used in SequenceMatcher predates, and is a little fancier than, an algorithm published in the late 1980s b... - https://man.mtool.work/python/3.14/library/difflib.html
- hashlib --- セキュアハッシュとメッセージダイジェスト — Python 3.14.8 ドキュメン... 8218
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » The Python standard library » 暗号関連のサービス » hashlib --- セキュアハッシュとメッセージダイジェスト テーマ 自動 ライト ダーク | hashlib --- セキュアハッシュと
...メッセージダイジェスト ¶ ソースコード: Lib/hashlib.py This module implements a common interface to many different hash algorithms. Included are the FIPS secure hash algorithms SHA224, SHA256, SHA384, SHA512, (defined in the FIPS 180-4 standard ), the...SHA-3 series (defined in the FIPS 202 standard ) as well as the legacy algorithms SHA1 ( formerly part of FIPS ) and the MD5 algorithm (defined in internet RFC 1321 ). 注釈 adler32 や crc32 ハッシュ関数は...computing a hash supplied more than 2047 bytes of data at once in its constructor or .update method. Constructors for hash algorithms that are always present in this module are sha1() , sha224() , sha256() , sha384() , sha512() , sha3_224() , sha3_256() ,... - https://man.mtool.work/python/3.14/library/hashlib.html
- The Python 2.3 Method Resolution Order — Python 3.14.8 ドキュメント 7967
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » Python HOWTO » The Python 2.3 Method Resolution Order テーマ 自動 ライト ダーク | The Python 2.3 Method Resolution Order ¶ 注釈 This is a historical document, pr
...t is described in a paper intended for lispers [ 2 ] . The present paper gives a (hopefully) readable discussion of the C3 algorithm for Pythonistas who want to understand the reasons for the change. First of all, let me point out that what I am going to...less you make strong use of multiple inheritance and you have non-trivial hierarchies, you don't need to understand the C3 algorithm, and you can easily skip this paper. On the other hand, if you really want to know how multiple inheritance works, then th...s XYO and YXO, since X is in the tail of YXO whereas Y is in the tail of XYO: therefore there are no good heads and the C3 algorithm stops. Python 2.3 raises an error and refuses to create the class C. Bad Method Resolution Orders ¶ A MRO is bad when it b... - https://man.mtool.work/python/3.14/howto/mro.html
- hashlib --- セキュアハッシュとメッセージダイジェスト — Python 3.14.8 ドキュメン... 7967
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » The Python standard library » 暗号関連のサービス » hashlib --- セキュアハッシュとメッセージダイジェスト テーマ 自動 ライト ダーク | hashlib --- セキュアハッシュと
...メッセージダイジェスト ¶ ソースコード: Lib/hashlib.py This module implements a common interface to many different hash algorithms. Included are the FIPS secure hash algorithms SHA224, SHA256, SHA384, SHA512, (defined in the FIPS 180-4 standard ), the...SHA-3 series (defined in the FIPS 202 standard ) as well as the legacy algorithms SHA1 ( formerly part of FIPS ) and the MD5 algorithm (defined in internet RFC 1321 ). 注釈 adler32 や crc32 ハッシュ関数は...computing a hash supplied more than 2047 bytes of data at once in its constructor or .update method. Constructors for hash algorithms that are always present in this module are sha1() , sha224() , sha256() , sha384() , sha512() , sha3_224() , sha3_256() ,... - https://man.mtool.work/python/3.14/library/hashlib.html
- The Python 2.3 Method Resolution Order — Python 3.14.8 ドキュメント 7967
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » Python HOWTO » The Python 2.3 Method Resolution Order テーマ 自動 ライト ダーク | The Python 2.3 Method Resolution Order ¶ 注釈 This is a historical document, pr
...t is described in a paper intended for lispers [ 2 ] . The present paper gives a (hopefully) readable discussion of the C3 algorithm for Pythonistas who want to understand the reasons for the change. First of all, let me point out that what I am going to...less you make strong use of multiple inheritance and you have non-trivial hierarchies, you don't need to understand the C3 algorithm, and you can easily skip this paper. On the other hand, if you really want to know how multiple inheritance works, then th...s XYO and YXO, since X is in the tail of YXO whereas Y is in the tail of XYO: therefore there are no good heads and the C3 algorithm stops. Python 2.3 raises an error and refuses to create the class C. Bad Method Resolution Orders ¶ A MRO is bad when it b... - https://man.mtool.work/python/3.14/howto/mro.html
- email.policy: Policy Objects — Python 3.14.8 ドキュメント 7128
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » The Python standard library » インターネット上のデータの操作 » email --- 電子メールと MIME 処理のためのパッケージ » email.policy : Policy Objects テーマ 自動 ライ
...(but are not limited to) RFC 5322 , RFC 2047 , and the current MIME RFCs. This policy adds new header parsing and folding algorithms. Instead of simple strings, headers are str subclasses with attributes that depend on the type of the field. The parsing...and folding algorithm fully implement RFC 2047 and RFC 5322 . The default value for the message_factory attribute is EmailMessage . In addition...ect created and returned. Any header object, or any header that is refolded due to the policy settings, is folded using an algorithm that fully implements the RFC folding algorithms, including knowing where encoded words are required and allowed. From the... - https://man.mtool.work/python/3.14/library/email.policy.html
- email.policy: Policy Objects — Python 3.14.8 ドキュメント 7128
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » The Python standard library » インターネット上のデータの操作 » email --- 電子メールと MIME 処理のためのパッケージ » email.policy : Policy Objects テーマ 自動 ライ
...(but are not limited to) RFC 5322 , RFC 2047 , and the current MIME RFCs. This policy adds new header parsing and folding algorithms. Instead of simple strings, headers are str subclasses with attributes that depend on the type of the field. The parsing...and folding algorithm fully implement RFC 2047 and RFC 5322 . The default value for the message_factory attribute is EmailMessage . In addition...ect created and returned. Any header object, or any header that is refolded due to the policy settings, is folded using an algorithm that fully implements the RFC folding algorithms, including knowing where encoded words are required and allowed. From the... - https://man.mtool.work/python/3.14/library/email.policy.html