Results of 1 - 10 of about 23 for RFCs (0.003 sec.)
- email --- 電子メールと MIME 処理のためのパッケージ — Python 3.14.8 ドキュメント 13120
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » The Python standard library » インターネット上のデータの操作 » email --- 電子メールと MIME 処理のためのパッケージ テーマ 自動 ライト ダーク | email --- 電子メール
...email package attempts to be as RFC-compliant as possible, supporting RFC 5322 and RFC 6532 , as well as such MIME-related RFCs as RFC 2045 , RFC 2046 , RFC 2047 , RFC 2183 , and RFC 2231 . The overall structure of the email package can be divided in...settings when sending it to an email server. The email package does its best to hide the details of the various governing RFCs from the application. Conceptually the application should be able to treat the email message as a structured tree of Unico...f the library. The next three sections cover the exceptions the package may raise and the defects (non-compliance with the RFCs) that the parser may detect. Then we cover the headerregistry and the contentmanager sub-components, which provide tools f... - https://man.mtool.work/python/3.14/library/email.html
- email --- 電子メールと MIME 処理のためのパッケージ — Python 3.14.8 ドキュメント 13120
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » The Python standard library » インターネット上のデータの操作 » email --- 電子メールと MIME 処理のためのパッケージ テーマ 自動 ライト ダーク | email --- 電子メール
...email package attempts to be as RFC-compliant as possible, supporting RFC 5322 and RFC 6532 , as well as such MIME-related RFCs as RFC 2045 , RFC 2046 , RFC 2047 , RFC 2183 , and RFC 2231 . The overall structure of the email package can be divided in...settings when sending it to an email server. The email package does its best to hide the details of the various governing RFCs from the application. Conceptually the application should be able to treat the email message as a structured tree of Unico...f the library. The next three sections cover the exceptions the package may raise and the defects (non-compliance with the RFCs) that the parser may detect. Then we cover the headerregistry and the contentmanager sub-components, which provide tools f... - https://man.mtool.work/python/3.14/library/email.html
- email.policy: Policy Objects — Python 3.14.8 ドキュメント 10271
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » The Python standard library » インターネット上のデータの操作 » email --- 電子メールと MIME 処理のためのパッケージ » email.policy : Policy Objects テーマ 自動 ライ
...utput. The default is \n because that's the internal end-of-line discipline used by Python, though \r\n is required by the RFCs. cte_type ¶ Controls the type of Content Transfer Encodings that may be or are required to be used. The possible values ar...ailPolicy ( ** kw ) ¶ This concrete Policy provides behavior that is intended to be fully compliant with the current email RFCs. These include (but are not limited to) RFC 5322 , RFC 2047 , and the current MIME RFCs. This policy adds new header parsi...ture the behavior of these instances (in particular the HTTP instance) may be adjusted to conform even more closely to the RFCs relevant to their domains. email.policy. default ¶ デフォルト値を変更していない EmailPolicy のインスタンスです。このポリシ... - https://man.mtool.work/python/3.14/library/email.policy.html
- email.policy: Policy Objects — Python 3.14.8 ドキュメント 10271
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » The Python standard library » インターネット上のデータの操作 » email --- 電子メールと MIME 処理のためのパッケージ » email.policy : Policy Objects テーマ 自動 ライ
...utput. The default is \n because that's the internal end-of-line discipline used by Python, though \r\n is required by the RFCs. cte_type ¶ Controls the type of Content Transfer Encodings that may be or are required to be used. The possible values ar...ailPolicy ( ** kw ) ¶ This concrete Policy provides behavior that is intended to be fully compliant with the current email RFCs. These include (but are not limited to) RFC 5322 , RFC 2047 , and the current MIME RFCs. This policy adds new header parsi...ture the behavior of these instances (in particular the HTTP instance) may be adjusted to conform even more closely to the RFCs relevant to their domains. email.policy. default ¶ デフォルト値を変更していない EmailPolicy のインスタンスです。このポリシ... - https://man.mtool.work/python/3.14/library/email.policy.html
- email.header: 国際化されたヘッダー — Python 3.14.8 ドキュメント 8663
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » The Python standard library » インターネット上のデータの操作 » email --- 電子メールと MIME 処理のためのパッケージ » email.header : 国際化されたヘッダー テーマ 自
...essages. The base standard still requires email messages to be transferred using only 7-bit ASCII characters, so a slew of RFCs have been written describing how to encode email containing non-ASCII characters into RFC 2822 -compliant format. These RF... - https://man.mtool.work/python/3.14/library/email.header.html
- email.header: 国際化されたヘッダー — Python 3.14.8 ドキュメント 8663
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » The Python standard library » インターネット上のデータの操作 » email --- 電子メールと MIME 処理のためのパッケージ » email.header : 国際化されたヘッダー テーマ 自
...essages. The base standard still requires email messages to be transferred using only 7-bit ASCII characters, so a slew of RFCs have been written describing how to encode email containing non-ASCII characters into RFC 2822 -compliant format. These RF... - https://man.mtool.work/python/3.14/library/email.header.html
- email.generator: Generating MIME documents — Python 3.14.8 ドキュメント 7858
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » The Python standard library » インターネット上のデータの操作 » email --- 電子メールと MIME 処理のためのパッケージ » email.generator : Generating MIME documents テ
...ompatible format, by converting them to an ASCII compatible Content-Transfer_Encoding . Using the terminology of the email RFCs, you can think of this as Generator serializing to an I/O stream that is not "8 bit clean". In other words, most applicati...ld_source must be none , which is not the default). It is also not 100% true, since if the message does not conform to the RFC standards occasionally information about the exact original text is lost during parsing error recovery. It is a goal to fix... - https://man.mtool.work/python/3.14/library/email.generator.html
- email.utils: Miscellaneous utilities — Python 3.14.8 ドキュメント 7858
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » The Python standard library » インターネット上のデータの操作 » email --- 電子メールと MIME 処理のためのパッケージ » email.utils : Miscellaneous utilities テーマ
.... If the input date has a timezone of -0000 , the datetime will be a naive datetime , and if the date is conforming to the RFCs it will represent a time in UTC but with no indication of the actual source timezone of the message the date comes from. I... - https://man.mtool.work/python/3.14/library/email.utils.html
- email.generator: Generating MIME documents — Python 3.14.8 ドキュメント 7858
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » The Python standard library » インターネット上のデータの操作 » email --- 電子メールと MIME 処理のためのパッケージ » email.generator : Generating MIME documents テ
...ompatible format, by converting them to an ASCII compatible Content-Transfer_Encoding . Using the terminology of the email RFCs, you can think of this as Generator serializing to an I/O stream that is not "8 bit clean". In other words, most applicati...ld_source must be none , which is not the default). It is also not 100% true, since if the message does not conform to the RFC standards occasionally information about the exact original text is lost during parsing error recovery. It is a goal to fix... - https://man.mtool.work/python/3.14/library/email.generator.html
- email.utils: Miscellaneous utilities — Python 3.14.8 ドキュメント 7858
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » The Python standard library » インターネット上のデータの操作 » email --- 電子メールと MIME 処理のためのパッケージ » email.utils : Miscellaneous utilities テーマ
.... If the input date has a timezone of -0000 , the datetime will be a naive datetime , and if the date is conforming to the RFCs it will represent a time in UTC but with no indication of the actual source timezone of the message the date comes from. I... - https://man.mtool.work/python/3.14/library/email.utils.html