Results of 1 - 10 of about 100 for 規則 (0.008 sec.)
- Unix-specific services — Python 3.14.8 ドキュメント 11742
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » The Python standard library » Unix-specific services テーマ 自動 ライト ダーク | Unix-specific services ¶ 本章に記述されたモジュールは、Unix オペレーティングシス
...に固有の機能のためのインターフェースを提供します。その概要を以下に述べます: shlex --- 単純な字句解析 shlex オブジェクト 解析規則 Improved Compatibility with Shells posix --- 最も一般的な POSIX システムコール群 ラージファイルのサポート 注目すべきモジュ...ータベース 制御 fcntl syslog specific services 本章 記述 オペレーティングシステム 派生 固有 インターフェース 提供 概要 字句 規則 Improved Compatibility Shells 一般的 前のトピックへ winsound --- Windows 用の音声再生インターフェース 次のトピックへ shlex... - https://man.mtool.work/python/3.14/library/unix.html
- http.cookiejar --- HTTP クライアント用の Cookie 処理 — Python 3.14.8 ドキュメン... 10142
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » The Python standard library » インターネットプロトコルとサポート » http.cookiejar --- HTTP クライアント用の Cookie 処理 テーマ 自動 ライト ダーク | http.cookieja
...受けとったり設定したりするドメインを許可したり拒絶したりできるようになっています。ほかにも、 Netscape プロトコルのかなり緩い規則をややきつくするために、いくつかの厳密性のスイッチがついています (いくつかの良性クッキーをブロックする危険性もありますが)。...トランザクション (通常これはリダイレクトか、別のサイトがホスティングしているイメージの読み込み要求です) に関する RFC 2965 の規則に従います。この値が偽の場合、検証可能性を基準にしてクッキーがブロックされることは 決して ありません Netscape プロトコルの厳...密性に関するスイッチ: DefaultCookiePolicy. strict_ns_unverifiable ¶ 検証不可能なトランザクションに関する RFC 2965 の規則を Netscape クッキーに対しても適用します。 DefaultCookiePolicy. strict_ns_domain ¶ Netscape クッキーに対するドメインマッチン... - https://man.mtool.work/python/3.14/library/http.cookiejar.html
- http.cookies --- HTTP の状態管理 — Python 3.14.8 ドキュメント 10142
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » The Python standard library » インターネットプロトコルとサポート » http.cookies --- HTTP の状態管理 テーマ 自動 ライト ダーク | http.cookies --- HTTP の状態管理
...for having any serializable data-type as cookie value. このモジュールは元々 RFC 2109 と RFC 2068 に定義されている構文解析の規則を厳密に守っていました。しかし、MSIE 3.0x がこれらの RFC で定義された文字の規則に従っていなかったことが判明し、現在の多くのブ...ラウザーとサーバーも Cookie の処理に関しては緩い解析を行っています。結局、このモジュールは昔よりもやや厳密さを欠く構文解析規則になっています。 文字集合 string.ascii_letters 、 string.digits 、 !#$%&'*+-.^_`|~: を、このモジュールは cookie 名 ( key ) と... - https://man.mtool.work/python/3.14/library/http.cookies.html
- http.cookiejar --- HTTP クライアント用の Cookie 処理 — Python 3.14.8 ドキュメン... 10142
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » The Python standard library » インターネットプロトコルとサポート » http.cookiejar --- HTTP クライアント用の Cookie 処理 テーマ 自動 ライト ダーク | http.cookieja
...受けとったり設定したりするドメインを許可したり拒絶したりできるようになっています。ほかにも、 Netscape プロトコルのかなり緩い規則をややきつくするために、いくつかの厳密性のスイッチがついています (いくつかの良性クッキーをブロックする危険性もありますが)。...トランザクション (通常これはリダイレクトか、別のサイトがホスティングしているイメージの読み込み要求です) に関する RFC 2965 の規則に従います。この値が偽の場合、検証可能性を基準にしてクッキーがブロックされることは 決して ありません Netscape プロトコルの厳...密性に関するスイッチ: DefaultCookiePolicy. strict_ns_unverifiable ¶ 検証不可能なトランザクションに関する RFC 2965 の規則を Netscape クッキーに対しても適用します。 DefaultCookiePolicy. strict_ns_domain ¶ Netscape クッキーに対するドメインマッチン... - https://man.mtool.work/python/3.14/library/http.cookiejar.html
- http.cookies --- HTTP の状態管理 — Python 3.14.8 ドキュメント 10142
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » The Python standard library » インターネットプロトコルとサポート » http.cookies --- HTTP の状態管理 テーマ 自動 ライト ダーク | http.cookies --- HTTP の状態管理
...for having any serializable data-type as cookie value. このモジュールは元々 RFC 2109 と RFC 2068 に定義されている構文解析の規則を厳密に守っていました。しかし、MSIE 3.0x がこれらの RFC で定義された文字の規則に従っていなかったことが判明し、現在の多くのブ...ラウザーとサーバーも Cookie の処理に関しては緩い解析を行っています。結局、このモジュールは昔よりもやや厳密さを欠く構文解析規則になっています。 文字集合 string.ascii_letters 、 string.digits 、 !#$%&'*+-.^_`|~: を、このモジュールは cookie 名 ( key ) と... - https://man.mtool.work/python/3.14/library/http.cookies.html
- 循環参照ガベージコレクションをサポートする — Python 3.14.8 ドキュメント 9752
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » Python/C API reference manual » オブジェクト実装サポート (object implementation support) » 循環参照ガベージコレクションをサポートする テーマ 自動 ライト ダーク |
...tp_clear implementation must also be provided. Py_TPFLAGS_HAVE_GC このフラグをセットした型のオブジェクトは、この節に述べた規則に適合しなければなりません。簡単のため、このフラグをセットした型のオブジェクトをコンテナオブジェクトと呼びます。 コンテナ型の...コンストラクタは以下の二つの規則に適合しなければなりません: The memory for the object must be allocated using PyObject_GC_New or PyObject_GC_NewVar . 他のコ...初期化されたら、すぐに PyObject_GC_Track() を呼び出さなければなりません。 同様に、オブジェクトのメモリ解放関数も以下の二つの規則に適合しなければなりません: 他のコンテナを参照しているフィールドを無効化する前に、 PyObject_GC_UnTrack() を呼び出さなければな... - https://man.mtool.work/python/3.14/c-api/gcsupport.html
- 循環参照ガベージコレクションをサポートする — Python 3.14.8 ドキュメント 9752
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » Python/C API reference manual » オブジェクト実装サポート (object implementation support) » 循環参照ガベージコレクションをサポートする テーマ 自動 ライト ダーク |
...tp_clear implementation must also be provided. Py_TPFLAGS_HAVE_GC このフラグをセットした型のオブジェクトは、この節に述べた規則に適合しなければなりません。簡単のため、このフラグをセットした型のオブジェクトをコンテナオブジェクトと呼びます。 コンテナ型の...コンストラクタは以下の二つの規則に適合しなければなりません: The memory for the object must be allocated using PyObject_GC_New or PyObject_GC_NewVar . 他のコ...初期化されたら、すぐに PyObject_GC_Track() を呼び出さなければなりません。 同様に、オブジェクトのメモリ解放関数も以下の二つの規則に適合しなければなりません: 他のコンテナを参照しているフィールドを無効化する前に、 PyObject_GC_UnTrack() を呼び出さなければな... - https://man.mtool.work/python/3.14/c-api/gcsupport.html
- 1. Extending Python with C or C++ — Python 3.14.8 ドキュメント 8543
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » Python インタプリタの拡張と埋め込み » 1. Extending Python with C or C++ テーマ 自動 ライト ダーク | 1. Extending Python with C or C++ ¶ It is quite easy to add n
...度呼び出して、より詳細なエラーメッセージを提供するような状況があります。このような状況ではそうすべきです。とはいえ、一般的な規則としては、この関数を何度も呼び出す必要はなく、ともすればエラーの原因に関する情報を失う結果になりがちです: これにより、ほとん...ません。オブジェクトを生成する全ての関数 (例えば PyLong_FromLong() ) は PyErr_NoMemory() の呼び出しを済ませてしまうので、この規則が関係するのは直接 malloc() を呼び出すコードだけです。 また、 PyArg_ParseTuple() という重要な例外を除いて、整数の状態コードを...課します (つまり、新たな参照の所有者は、以前の所有者と同様、参照の放棄を適切に行わねばなりません)。 1.10.2. 所有権にまつわる規則 ¶ オブジェクトへの参照を関数の内外に渡す場合には、オブジェクトの所有権が参照と共に渡されるか否かが常に関数インターフェース... - https://man.mtool.work/python/3.14/extending/extending.html
- decimal --- 10進固定小数点と浮動小数点の演算 — Python 3.14.8 ドキュメント 8543
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » The Python standard library » 数値と数学モジュール » decimal --- 10進固定小数点と浮動小数点の演算 テーマ 自動 ライト ダーク | decimal --- 10進固定小数点と浮動小数
..., および NaN といった特殊な値も定義されています。標準仕様では -0 と +0 も区別します。 算術コンテキストとは、精度や値丸めの規則、指数部の制限を決めている環境です。この環境では、演算結果を表すためのフラグや、演算上発生した特定のシグナルを例外として扱う...かどうかを決めるトラップイネーブラも定義しています。丸め規則には ROUND_CEILING , ROUND_DOWN , ROUND_FLOOR , ROUND_HALF_DOWN , ROUND_HALF_EVEN , ROUND_HALF_UP , ROUND_UP , および ROUND_...排他的論理和です。 max ( other , context = None ) ¶ max(self, other) と同じですが、値を返す前に現在のコンテキストに即した丸め規則を適用します。また、 NaN に対して、(コンテキストの設定と、発信か無言どちらのタイプであるかに応じて) シグナルを発行するか無視... - https://man.mtool.work/python/3.14/library/decimal.html
- Unix-specific services — Python 3.14.8 ドキュメント 8543
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » The Python standard library » Unix-specific services テーマ 自動 ライト ダーク | Unix-specific services ¶ 本章に記述されたモジュールは、Unix オペレーティングシス
...に固有の機能のためのインターフェースを提供します。その概要を以下に述べます: shlex --- 単純な字句解析 shlex オブジェクト 解析規則 Improved Compatibility with Shells posix --- 最も一般的な POSIX システムコール群 ラージファイルのサポート 注目すべきモジュ... - https://man.mtool.work/python/3.14/library/unix.html