Results of 1 - 10 of about 217 for エンコード (0.007 sec.)
- codecs --- codec レジストリと基底クラス — Python 3.14.8 ドキュメント 9896
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » The Python standard library » バイナリデータ処理 » codecs --- codec レジストリと基底クラス テーマ 自動 ライト ダーク | codecs --- codec レジストリと基底クラス ¶
...とエラー処理検索プロセスを管理する内部の Python codec レジストリへのアクセスを提供します。多くの codec はテキストをバイトにエンコードする (そしてバイトをテキストにデコードする) テキストエンコーディング ですが、テキストをテキストに、またはバイトをバイトにエン...コードする codec も提供されています。カスタムの codec は任意の型間でエンコードとデコードを行えますが、一部のモジュール機能は テキストエンコーディング か bytes へのエンコードのみに制限されています。 この...モジュールでは、任意の codec でエンコードやデコードを行うための、以下の関数が定義されています。 codecs. encode ( obj , encoding = 'utf-8' , errors = 'strict' ) ¶ enc... - https://man.mtool.work/python/3.14/library/codecs.html
- codecs --- codec レジストリと基底クラス — Python 3.14.8 ドキュメント 9896
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » The Python standard library » バイナリデータ処理 » codecs --- codec レジストリと基底クラス テーマ 自動 ライト ダーク | codecs --- codec レジストリと基底クラス ¶
...とエラー処理検索プロセスを管理する内部の Python codec レジストリへのアクセスを提供します。多くの codec はテキストをバイトにエンコードする (そしてバイトをテキストにデコードする) テキストエンコーディング ですが、テキストをテキストに、またはバイトをバイトにエン...コードする codec も提供されています。カスタムの codec は任意の型間でエンコードとデコードを行えますが、一部のモジュール機能は テキストエンコーディング か bytes へのエンコードのみに制限されています。 この...モジュールでは、任意の codec でエンコードやデコードを行うための、以下の関数が定義されています。 codecs. encode ( obj , encoding = 'utf-8' , errors = 'strict' ) ¶ enc... - https://man.mtool.work/python/3.14/library/codecs.html
- base64 --- Base16, Base32, Base64, Base85 データのエンコード — Python 3.14.8 ド... 8355
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » The Python standard library » インターネット上のデータの操作 » base64 --- Base16, Base32, Base64, Base85 データのエンコード テーマ 自動 ライト ダーク | base64 --
...- Base16, Base32, Base64, Base85 データのエンコード ¶ ソースコード: Lib/base64.py This module provides functions for encoding binary data to printable ASCII characters and de.... このモジュールは、2つのインターフェースを提供します。このモダンなインターフェースは、 bytes-like object を ASCII bytes にエンコードし、 bytes-like object か ASCII 文字列を、 bytes にデコードすることができます。 RFC 4648 に定義されている base-64 アルファベ...ステムセーフなもの) の両方が使用できます。 従来のインターフェース は文字列からのデコードができませんが、 file object との間のエンコードとデコードが可能な関数を提供します。これは標準の base64 アルファベットのみをサポートし、 RFC 2045 の規定にあるように、76文字... - https://man.mtool.work/python/3.14/library/base64.html
- base64 --- Base16, Base32, Base64, Base85 データのエンコード — Python 3.14.8 ド... 8334
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » The Python standard library » インターネット上のデータの操作 » base64 --- Base16, Base32, Base64, Base85 データのエンコード テーマ 自動 ライト ダーク | base64 --
...- Base16, Base32, Base64, Base85 データのエンコード ¶ ソースコード: Lib/base64.py This module provides functions for encoding binary data to printable ASCII characters and de.... このモジュールは、2つのインターフェースを提供します。このモダンなインターフェースは、 bytes-like object を ASCII bytes にエンコードし、 bytes-like object か ASCII 文字列を、 bytes にデコードすることができます。 RFC 4648 に定義されている base-64 アルファベ...ステムセーフなもの) の両方が使用できます。 従来のインターフェース は文字列からのデコードができませんが、 file object との間のエンコードとデコードが可能な関数を提供します。これは標準の base64 アルファベットのみをサポートし、 RFC 2045 の規定にあるように、76文字... - https://man.mtool.work/python/3.14/library/base64.html
- email.charset: 文字集合の表現 — Python 3.14.8 ドキュメント 8271
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » The Python standard library » インターネット上のデータの操作 » email --- 電子メールと MIME 処理のためのパッケージ » email.charset : 文字集合の表現 テーマ 自動 ラ
...報を提供するのに最善を尽くします。 文字集合によっては、電子メールのヘッダや本体で使う場合に quoted-printable や base64 形式でエンコードされなければなりません。 また、文字集合によっては完全に変換する必要があり、電子メールの中では使用できません。 以下ではオプシ...デックを見付けるのに使われます。たとえば input_charset が iso-8859-1 の場合、ヘッダおよびメッセージ本体は quoted-printable でエンコードされ、出力時の変換用コーデックは必要ありません。もし input_charset が euc-jp ならば、ヘッダは base64 でエンコードされ、メッセ...ージ本体はエンコードされませんが、出力されるテキストは euc-jp 文字集合から iso-2022-jp 文字集合に変換されます。 Charset インスタンスは以下のよう... - https://man.mtool.work/python/3.14/library/email.charset.html
- email.charset: 文字集合の表現 — Python 3.14.8 ドキュメント 8271
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » The Python standard library » インターネット上のデータの操作 » email --- 電子メールと MIME 処理のためのパッケージ » email.charset : 文字集合の表現 テーマ 自動 ラ
...報を提供するのに最善を尽くします。 文字集合によっては、電子メールのヘッダや本体で使う場合に quoted-printable や base64 形式でエンコードされなければなりません。 また、文字集合によっては完全に変換する必要があり、電子メールの中では使用できません。 以下ではオプシ...デックを見付けるのに使われます。たとえば input_charset が iso-8859-1 の場合、ヘッダおよびメッセージ本体は quoted-printable でエンコードされ、出力時の変換用コーデックは必要ありません。もし input_charset が euc-jp ならば、ヘッダは base64 でエンコードされ、メッセ...ージ本体はエンコードされませんが、出力されるテキストは euc-jp 文字集合から iso-2022-jp 文字集合に変換されます。 Charset インスタンスは以下のよう... - https://man.mtool.work/python/3.14/library/email.charset.html
- Unicode HOWTO — Python 3.14.8 ドキュメント 8240
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » Python HOWTO » Unicode HOWTO テーマ 自動 ライト ダーク | Unicode HOWTO ¶ Release : 1.12 この HOWTO 文書は、文字データの表現のための Unicode 仕様の Python における
...クトです; よく使われている文字の大多数は 1 バイトか 2 バイトで表現できます。 バイトが欠落したり、失われた場合、次の UTF-8 でエンコードされたコードポイントの開始を決定し、再同期することができる可能性があります。同様の理由でランダムな 8-bit データは正当な UTF-...変換 ¶ bytes.decode() とは処理が逆向きのメソッドが str.encode() です。このメソッドは、 Unicode 文字列を指定された encoding でエンコードして、 bytes による表現で返します。 errors 引数は decode() メソッドのパラメータと同じものですが、サポートされているハンドラの...数がもう少し多いです。 'strict' 、 'ignore' 、 'replace' (このメソッドでは、エンコードできなかった文字の代わりに疑問符を挿入する) の他に、 'xmlcharrefreplace' (XML 文字参照を挿入する) と backslashreplace (エスケ... - https://man.mtool.work/python/3.14/howto/unicode.html
- Unicode HOWTO — Python 3.14.8 ドキュメント 8240
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » Python HOWTO » Unicode HOWTO テーマ 自動 ライト ダーク | Unicode HOWTO ¶ Release : 1.12 この HOWTO 文書は、文字データの表現のための Unicode 仕様の Python における
...クトです; よく使われている文字の大多数は 1 バイトか 2 バイトで表現できます。 バイトが欠落したり、失われた場合、次の UTF-8 でエンコードされたコードポイントの開始を決定し、再同期することができる可能性があります。同様の理由でランダムな 8-bit データは正当な UTF-...変換 ¶ bytes.decode() とは処理が逆向きのメソッドが str.encode() です。このメソッドは、 Unicode 文字列を指定された encoding でエンコードして、 bytes による表現で返します。 errors 引数は decode() メソッドのパラメータと同じものですが、サポートされているハンドラの...数がもう少し多いです。 'strict' 、 'ignore' 、 'replace' (このメソッドでは、エンコードできなかった文字の代わりに疑問符を挿入する) の他に、 'xmlcharrefreplace' (XML 文字参照を挿入する) と backslashreplace (エスケ... - https://man.mtool.work/python/3.14/howto/unicode.html
- quopri --- MIME quoted-printable データのエンコードとデコード — Python 3.14.8 ... 8208
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » The Python standard library » インターネット上のデータの操作 » quopri --- MIME quoted-printable データのエンコードとデコード テーマ 自動 ライト ダーク | quopri -
...-- MIME quoted-printable データのエンコードとデコード ¶ ソースコード: Lib/quopri.py このモジュールは RFC 1521 : "MIME (Multipurpose Internet Mail Extensions) Part One:...hanisms for Specifying and Describing the Format of Internet Message Bodies" で定義されている quoted-printable による伝送のエンコードおよびデコードを行います。 quoted-printable エンコーディングは比較的印字不可能な文字の少ないデータのために設計されています;...ultipurpose Internet Mail Extensions) Part Two: Message Header Extensions for Non-ASCII Text" で記述されているところの "Q"-エンコードされたヘッダをデコードするのに使われます。 quopri. encode ( input , output , quotetabs , header = False ) ¶ ファイル input の... - https://man.mtool.work/python/3.14/library/quopri.html
- quopri --- MIME quoted-printable データのエンコードとデコード — Python 3.14.8 ... 8072
- ナビゲーション 索引 モジュール | 次へ | 前へ | Python » 3.14.8 Documentation » The Python standard library » インターネット上のデータの操作 » quopri --- MIME quoted-printable データのエンコードとデコード テーマ 自動 ライト ダーク | quopri -
...-- MIME quoted-printable データのエンコードとデコード ¶ ソースコード: Lib/quopri.py このモジュールは RFC 1521 : "MIME (Multipurpose Internet Mail Extensions) Part One:...hanisms for Specifying and Describing the Format of Internet Message Bodies" で定義されている quoted-printable による伝送のエンコードおよびデコードを行います。 quoted-printable エンコーディングは比較的印字不可能な文字の少ないデータのために設計されています;...ultipurpose Internet Mail Extensions) Part Two: Message Header Extensions for Non-ASCII Text" で記述されているところの "Q"-エンコードされたヘッダをデコードするのに使われます。 quopri. encode ( input , output , quotetabs , header = False ) ¶ ファイル input の... - https://man.mtool.work/python/3.14/library/quopri.html