JM Project

JM プロジェクトは、主に Linux 関連のマニュアルページの日本語ページを翻訳・公開しています。

Linux マニュアル 一覧

全文・高度検索

per page, with , order by , clip by
Results of 1 - 10 of about 22 for discard (0.004 sec.)
Man page of SWAPON 12726
SWAPON Section: Linux Programmer's Manual (2) Updated: 2017-09-15 Index JM Home Page 名前 swapon, swapoff - ファイル/デバイスへのスワップを開始/停止する 書式 #include < unistd.h > #include < sys/swap.h > int swapon(const char * path , int s ... 持つ。 優先度は以下のように変換されて swapflags に指定する。 (prio << SWAP_FLAG_PRIO_SHIFT) & SWAP_FLAG_PRIO_MASK SWAP_FLAG_DISCARD フラグが swapon () の swapflags 引数に指定された場合、 スワップデバイスが破棄 (discard) 操作や trim 操作をサポートしている ... この上限がさらに 1 少ない値となる。 スワップページの破棄は、カーネル 2.6.29 で導入され、その後カーネル 2.6.36 で SWAP_FLAG_DISCARD フラグが指定された場合にだけ実行されるようになったが、 今でも、このフラグビットが指定されていない場合であっても、 swapon が ...
https://man.mtool.work/man/20261015/man2/swapoff.2.html
Man page of SWAPON 12726
SWAPON Section: Linux Programmer's Manual (2) Updated: 2017-09-15 Index JM Home Page 名前 swapon, swapoff - ファイル/デバイスへのスワップを開始/停止する 書式 #include < unistd.h > #include < sys/swap.h > int swapon(const char * path , int s ... 持つ。 優先度は以下のように変換されて swapflags に指定する。 (prio << SWAP_FLAG_PRIO_SHIFT) & SWAP_FLAG_PRIO_MASK SWAP_FLAG_DISCARD フラグが swapon () の swapflags 引数に指定された場合、 スワップデバイスが破棄 (discard) 操作や trim 操作をサポートしている ... この上限がさらに 1 少ない値となる。 スワップページの破棄は、カーネル 2.6.29 で導入され、その後カーネル 2.6.36 で SWAP_FLAG_DISCARD フラグが指定された場合にだけ実行されるようになったが、 今でも、このフラグビットが指定されていない場合であっても、 swapon が ...
https://man.mtool.work/man/20261015/man2/swapon.2.html
Man page of STRIP 11666
STRIP Section: GNU Development Tools (1) Updated: 2025-10-13 Index JM Home Page 名前 strip - オブジェクトファイルからシンボルやその他のデータを削除 書式 strip [ -F bfdname | --target= bfdname ] [ -I bfdname | --input-target= bfdname ] [ -O ... e ] [ -M | --merge-notes ][ --no-merge-notes ] [ -N symbolname | --strip-symbol= symbolname ] [ -w | --wildcard ] [ -x | --discard-all ] [ -X | --discard-locals ] [ -R sectionname | --remove-section= sectionname ] [ --keep-section= sectionpattern ] [ -- ... -w -K !foo -K fo* これは strip に「fo」という文字で始まるシンボルだけを保持し、「foo」というシンボルを破棄させます。 -x --discard-all 非グローバルなシンボルを削除します。 -X --discard-locals コンパイラが生成したローカルシンボルを削除します。 (通常 "L" ...
https://man.mtool.work/man/20261015/man1/strip.1.html
Man page of OBJCOPY 9208
OBJCOPY Section: GNU Development Tools (1) Updated: 2025-10-13 Index JM Home Page 名前 objcopy - オブジェクトファイルのコピーや変換を行う 書式 objcopy [ -F bfdname | --target= bfdname ] [ -I bfdname | --input-target= bfdname ] [ -O bfdname ... ymbolname ] [ --globalize-symbols= filename ] [ -W symbolname | --weaken-symbol= symbolname ] [ -w | --wildcard ] [ -x | --discard-all ] [ -X | --discard-locals ] [ -b byte | --byte= byte ] [ -i [ breadth ]| --interleave [= breadth ]] [ --interleave-wid ... うなものです: -w -W !foo -W fo* これは objcopy が「foo」以外の「fo」で始まるすべてのシンボルを弱くする原因となります。 -x --discard-all 入力ファイルのグローバルでないシンボルはコピーしません。 -X --discard-locals コンパイラが生成したローカルなシンボルはコ ...
https://man.mtool.work/man/20261015/man1/objcopy.1.html
Man page of XINETD.CONF 9208
XINETD.CONF Section: File Formats (5) Updated: 14 June 2001 Index JM Home Page 名前 xinetd.conf - 拡張されたインターネットサービスデーモンの設定ファイル 説明 xinetd.conf は xinetd によって提供されるサービスを決定する設定ファイルである。 行の ... ービス xinetd は以下のサービスを内部的に提供する (ストリーム型、データグラム型の両方とも): echo , time , daytime , chargen , discard である。 xinetd が他のプロセスへと fork する必要がないということを除けば、 これらのサービスは、他のサービスと同様にアクセス ... 制限の下にある。 これら ( time , daytime と、データグラム型の echo , chargen , discard ) は instances の数に制限がない。 xinetd はまた、二つの UNLISTED なストリーム型内部サービスを提供する: servers と services ... er/some_server port = 20020 } 関連項目 xinetd (1L), xinetd.log (5) Postel J., Echo Protocol , RFC 862, May 1983 Postel J., Discard Protocol , RFC 863, May 1983 Postel J., Character Generator Protocol , RFC 864, May 1983 Postel J., Daytime Protocol , RFC ...
https://man.mtool.work/man/20261015/man5/xinetd.conf.5.html
Man page of BLOCKDEV 8854
BLOCKDEV Section: System Administration (8) Updated: August 2010 Index JM Home Page 名前 blockdev - コマンドラインからブロックデバイスの ioctl を呼び出す 書式 blockdev [ -q ] [ -v ] command [ command ...] device [ device ...] blockdev --rep ... ロジーというのは、デバイス固有の物理セクタサイズ、論理セクタサイズ、最小 I/O サイズなどのこと。特に、物理セクタサイズ。 --getdiscardzeroes discard zeroes サポートの状態を取得する。 --getfra ファイルシステムの先読み (readahead) の大きさを 512-byte セクタ単 ...
https://man.mtool.work/man/20261015/man8/blockdev.8.html
Man page of INETD 8147
INETD Section: Maintenance Commands (8) Index JM Home Page BSD mandoc Linux NetKit (0.17) 名前 inetd - インターネット ``スーパーサーバー'' 書式 inetd [- di ] [- q queuelength ] [ configuration file ] 説明 inetd は通常ブート時に /etc/rc.loca ... ' を指定する。 組み込み関数 inetd は、内蔵ルーチンを用いて簡単なサービスを自身で提供する。 これらのサービスとは ``echo'' ``discard'' ``chargen'' (文字生成), ``daytime'' (人間が読む形式で時間を出力), ``time'' (機械可読形式の時間。1900 年 1 月 1 日 0 時か ...
https://man.mtool.work/man/20261015/man8/inetd.8.html
Man page of LSBLK 8147
LSBLK Section: System Administration (8) Updated: February 2013 Index JM Home Page 名前 lsblk - ブロックデバイスを一覧表示する 書式 lsblk [options] [ device ...] 説明 lsblk は、利用できるすべてのブロックデバイス、 または指定されたブロックデ ... ィスクデバイスもリストする。 -b , --bytes SIZE の項目 (column) を人間に読みやすい表記ではなく、バイト単位で表示する。 -D , --discard 各デバイスについて、そのディスカーディング能力 (discarding capabilities、TRIM や UNMAP) の情報を表示する。 -d , --nodeps ホ ...
https://man.mtool.work/man/20261015/man8/lsblk.8.html
Man page of REFER 7457
REFER Section: User Commands (1) Updated: 6 August 2001 Index JM Home Page 名称 refer - groff のための参考文献目録プリプロセッサ 書式 refer [ -benvCPRS ] [ -a n ] [ -c fields ] [ -f n ] [ -i fields ] [ -k field ] [ -l m,n ] [ -p filename ] ... べきかどうかを決定します。 そのため no-default-database コマンドを有効とするためには、それ以前に指定しておく必要があります。 discard* fields 参考文献が読み込まれた時、 fields を無効とします。 fields の文字列の定義は出力されません。 初期状態では fields は ...
https://man.mtool.work/man/20261015/man1/refer.1.html
Man page of TERMIOS 7457
TERMIOS Section: Linux Programmer's Manual (3) Updated: 2020-08-13 Index JM Home Page 名前 termios, tcgetattr, tcsetattr, tcsendbreak, tcdrain, tcflush, tcflow, cfmakeraw, cfgetospeed, cfgetispeed, cfsetispeed, cfsetospeed, cfsetspeed - ター ... コーする。 (Linux では実装されていない) FLUSHO (POSIX にはない; Linux では対応していない) 出力をフラッシュする。このフラグは DISCARD 文字を入力することで切替えられる。 [ _BSD_SOURCE か _SVID_SOURCE が必要] NOFLSH INT, QUIT, SUSP 文字に対応するシグナルを発 ... フラグを有効にするために必要である。 c_cc 配列は端末特殊文字を定義している。 シンボルの一覧 (初期値) と意味は以下の通り。 VDISCARD (POSIX にはない; Linux では対応していない; 017, SI, Ctrl-O) 未送信バッファーの内容の破棄/保存を切り替える。 IEXTEN がセット ... ECHO* processing) continues, but any input data after 4095 characters up to (but not including) any terminating newline is discarded. This ensures that the terminal can always receive more input until at least one line can be read. In noncanonical mode ...
https://man.mtool.work/man/20261015/man3/cfgetispeed.3.html
PREV 1 2 3 NEXT

リンク

日本語の文書やマニュアルを配布している個人/プロジェクトへのリンクです。