JM プロジェクトは、主に Linux 関連のマニュアルページの日本語ページを翻訳・公開しています。
... oo Big" パケットをブロックしている犯罪的に頭のいかれた ISP やサーバーを乗り越えるために使用される。 Linux ファイアウォール/ルーターでは何も問題がないのに、 そこにぶら下がるマシンでは以下のように大きなパケットをやりとりできないというのが、 この問題の兆候で ... ... を実装している。 ip には RFC 1112 に準拠した level 2 マルチキャストの実装が含まれている。 またパケットフィルタ機能を含む IP ルーターも実装されている。 プログラミングインターフェースは BSD ソケットと互換である。 ソケットに関するより詳細な情報は socket (7) を ... アウォールがローカル側のネットワークに唯一のリンクを持っている 場合や、透過プロクシの場合に限って有効にすべきである。 通常のルーターやホストでは決して使用することのないように。 さもないとフラグメントが別のリンクを経由して伝わる場合に、 通信のフラグメント化 ... れていないインターフェースが経路上に存在すると失敗してしまう。 Path MTU Discovery をグローバルに無効にするよりは、 壊れているルーターを直すほうが良い。 Path MTU Discovery を無効にするとネットワークのコストが 大きくなってしまうからである。 ip_nonlocal_bind ( ... ... トワーク経路を監視する。 このモードでは 2 つのポートが互いに「見える」ような ネットワーク設定が必要である (つまり、ポート間にルーターがあってはならない)。 CheckSeg ローカルポートとセグメントをチェックする。 このモードは CheckLocalPort モードと同じ機能を提供 ... ... ーの原因となったパケットを 受信したインターフェースのプライマリアドレスで送信される。 この動作は、多くのネットワーク管理者がルーターに対して期待しているものであり、 これにより複雑なネットワークレイアウトのデバッグがより容易になる。 選択されたインターフェー ... イマリアドレスが使用される点に 注意すること。 icmp_ignore_bogus_error_responses (ブール値; デフォルト: 無効; Linux 2.2 以降) ルーターの中には、RFC1122 に違反し、ブロードキャストフレームに対して 偽の応答を送信するものがある。 このような違反は通常カーネルの警 ... 装では、 IPPROTO_ICMP raw ソケットがサポートされていない。 この機能は移植性が必要なプログラムでは用いるべきでない。 Linux がルーターとして動作していないときには、 ICMP_REDIRECT パケットは送信されない。 またこれらが受け取られるのも、発信元がルーティングテー ... ... ト (RTO) からの 復旧性能を向上させたアルゴリズムである。 この機能は無線環境で特に効果を発揮する。 無線環境では、通常は、中間ルーターの輻輳ではなくランダムな無線の干渉 によりパケットロスが発生する。 詳細は RFC 4138 を参照。 このファイルは以下のいずれかの値を ... 日本語の文書やマニュアルを配布している個人/プロジェクトへのリンクです。