JM Project

JM プロジェクトは、主に Linux 関連のマニュアルページの日本語ページを翻訳・公開しています。

Linux マニュアル 一覧

全文・高度検索

per page, with , order by , clip by
Results of 1 - 6 of about 6 for udplite (0.004 sec.)
Man page of UDPLITE 13215
UDPLITE Section: Linux Programmer's Manual (7) Updated: 2017-09-15 Index JM Home Page 名前 udplite - 軽量なユーザーデータグラムプロトコル 書式 #include < sys/socket.h > sockfd = socket(AF_INET, SOCK_DGRAM, IPPROTO_UDPLITE); 説明 これは RFC ... アドレスを使用する。 ソケットオプション UDP-Lite のソケットオプションを設定/取得するには、 オプションレベル引数に IPPROTO_UDPLITE を指定して、取得時には getsockopt (2) を、設定時には setsockopt (2) を呼び出す。さらに、全ての IPPROTO_UDP のソケットオプシ ... ョンが UDP-Lite ソケットでも使用できる。 詳細は udp (7) を参照のこと。 以下の 2 つが UDP-Lite に固有のオプションである。 UDPLITE_SEND_CSCOV このオプションは送信側のチェックサムの対象範囲を設定する。 int 型を引数として取り、設定可能な値の範囲は 0 から ... に黙って切り詰められる。 現在の対象範囲の値を知りたければ、いつでも getsockopt (2) を使って値を問い合わせることができる。 UDPLITE_RECV_CSCOV これは受信側のチェックサムの対象範囲を設定するもので、 使用される引数形式と値の範囲は UDPLITE_SEND_CSCOV と同じ ...
https://man.mtool.work/man/20260915/man7/udplite.7.html
Man page of IP 8371
IP Section: Linux Programmer's Manual (7) Updated: 2020-11-01 Index JM Home Page 名前 ip - Linux IPv4 プロトコルの実装 書式 #include < sys/socket.h > #include < netinet/in.h > #include < netinet/ip.h > /* 上記のスーパーセット */ tcp_socket ... tream sockets; • 0 and IPPROTO_UDP for udp (7) datagram sockets; • IPPROTO_SCTP for sctp (7) stream sockets; and • IPPROTO_UDPLITE for udplite (7) datagram sockets. For SOCK_RAW you may specify a valid IANA IP protocol defined in RFC 1700 assigned numbe ...
https://man.mtool.work/man/20260915/man7/ip.7.html
Man page of UDP 8371
UDP Section: Linux Programmer's Manual (7) Updated: 2020-04-11 Index JM Home Page 名前 udp - IPv4 の ユーザーデータグラムプロトコル 書式 #include < sys/socket.h > #include < netinet/in.h > #include < netinet/udp.h > udp_socket = socket(AF_I ... っているからであることが多い。 バージョン IP_RECVERR は Linux 2.2 の新しい機能である。 関連項目 ip (7), raw (7), socket (7), udplite (7) The kernel source file Documentation/networking/ip-sysctl.txt . RFC 768 : User Datagram Protocol RFC 1122 : ホストの必 ...
https://man.mtool.work/man/20260915/man7/udp.7.html
Man page of iptables-extensions 8371
iptables-extensions Section: iptables 1.4.21 (8) Updated: Index JM Home Page 名前 iptables-extensions --- 標準の iptables に含まれる拡張モジュールのリスト 書式 ip6tables [ -m name [ module-options ...]] [ -j target-name [ target-options ... ... 5 個まで指定できる。 ポートの範囲指定 (port:port) は 2 ポートとカウントされる。 このモジュールが使用できるのは tcp , udp , udplite , dccp , sctp のいずれかと組み合わせた場合だけである。 [ ! ] --source-ports , --sports port [ , port | , port : port ]... ... e address (IPv4, IPv6 address), dst meaning destination address (IPv4, IPv6 address), sport meaning source port (TCP, UDP, UDPlite, SCTP, DCCP), dport meaning destination port (TCP, UDP, UDPlite, SCTP, DCCP), spi meaning Security Parameter Index (AH, ES ...
https://man.mtool.work/man/20260915/man8/iptables-extensions.8.html
Man page of IPTABLES 8225
IPTABLES Section: iptables 1.4.21 (8) Updated: Index JM Home Page 名前 iptables/ip6tables --- IPv4/IPv6 のパケットフィルタと NAT の管理ツール 書式 iptables [ -t table ] { -A | -C | -D } chain rule-specification ip6tables [ -t table ] { -A | ... tocol protocol ルールで使われるプロトコル、またはチェックされるパケットのプロトコル。 指定できるプロトコルは、 tcp , udp , udplite , icmp , esp , ah , sctp と特別なキーワード all のいずれか 1 つか、または数値である。 数値には、これらのプロトコルのどれか ...
https://man.mtool.work/man/20260915/man8/ip6tables.8.html
Man page of IPTABLES 8225
IPTABLES Section: iptables 1.4.21 (8) Updated: Index JM Home Page 名前 iptables/ip6tables --- IPv4/IPv6 のパケットフィルタと NAT の管理ツール 書式 iptables [ -t table ] { -A | -C | -D } chain rule-specification ip6tables [ -t table ] { -A | ... tocol protocol ルールで使われるプロトコル、またはチェックされるパケットのプロトコル。 指定できるプロトコルは、 tcp , udp , udplite , icmp , esp , ah , sctp と特別なキーワード all のいずれか 1 つか、または数値である。 数値には、これらのプロトコルのどれか ...
https://man.mtool.work/man/20260915/man8/iptables.8.html
PREV 1 NEXT

リンク

日本語の文書やマニュアルを配布している個人/プロジェクトへのリンクです。