JM プロジェクトは、主に Linux 関連のマニュアルページの日本語ページを翻訳・公開しています。
... e] -a sysctl [-n] [-e] -A 説明 sysctl はカーネルのパラメータを実行時に修正するのに用いる。 変更できるパラメータは /proc/sys/ 以下にリス ... トされているものである。 Linux における sysctl の機能には procfs が必要である。 sysctl は sysctl データの読み書き両方に使える。 パラメータ variable 読み取りの対象とするキ ... てのエラーを無視する。 -N 名前のみを表示する。 プログラム補完を持つシェルで役立つ。 -q 値のセットを標準出力に表示しない。 -w sysctl の設定を変更する場合には、このオプションを指定する。 -p 指定されたファイルから読み込んだ内容を sysctl 設定にロードする (フ ... ... 置かれた空白も無視される。 ただし値は空白を含むことができる。 # または ; ではじまる行はコメントとみなされ、無視される。 例 # sysctl.conf sample # kernel.domainname = example.com ; この値には空白が入っており、このまま sysctl に書き込まれる!! kernel.modpro ... be = /sbin/mod probe 関連項目 sysctl (8) 著者 George Staikos, < staikos@0wned.org > ... ... s system call no longer exists on current kernels! See NOTES. _sysctl () コールはカーネルパラメーターを読み書きする。例えば、 ホストネームや同時にオープンできるファイルの最大数など。 引数は以下 ... の形式である。 struct __sysctl_args { int *name; /* integer vector describing variable */ int nlen; /* length of this vector */ void *oldval; /* 0 or add ... る。 そして、要求された項目が見つかった場合は適切なルーチンを呼び出して 値を読んだり修正したりする。 返り値 成功した場合は _sysctl () は 0 を返す。失敗した場合、-1 が返され、 errno がそのエラーを示す値に設定される。 エラー EACCES か EPERM 「ディレクトリ ... ... s system call no longer exists on current kernels! See NOTES. _sysctl () コールはカーネルパラメーターを読み書きする。例えば、 ホストネームや同時にオープンできるファイルの最大数など。 引数は以下 ... の形式である。 struct __sysctl_args { int *name; /* integer vector describing variable */ int nlen; /* length of this vector */ void *oldval; /* 0 or add ... る。 そして、要求された項目が見つかった場合は適切なルーチンを呼び出して 値を読んだり修正したりする。 返り値 成功した場合は _sysctl () は 0 を返す。失敗した場合、-1 が返され、 errno がそのエラーを示す値に設定される。 エラー EACCES か EPERM 「ディレクトリ ... ... one can set an override for the systemd (1) mechanism, using something like: # echo "kernel.core_pattern=core.%p" > \ /etc/sysctl.d/50-coredump.conf # /lib/systemd/systemd-sysctl It is also possible to temporarily (i.e., until the next reboot) change t ... es of core dump files to include the executable name as well as the number of the signal which triggered the core dump): # sysctl -w kernel.core_pattern="%e-%s.core" 注意 gdb (1) の gcore コマンドを使用すると、実行中のプロセスのコアダンプを取得できる。 ... ... ト情報を持っていないコネクションでは、 このマッチングは常に false を返す点に注意すること。 "net.netfilter.nf_conntrack_acct" sysctl フラグで、 新規 コネクションでバイト数/パケット数の計測が行われるかが制御できる。 sysctl フラグが変更されても、 既存のコネ ... :/64 -j DNPT --src-pfx 2001:e20:2000:40f::/64 --dst-pfx fd00::/64 IPv6 neighbor proxy を有効にする必要があるかもしれない。 sysctl -w net.ipv6.conf.all.proxy_ndp=1 また、変換されたフローに対するコネクション追跡を無効にするには NOTRACK ターゲットを使用す ... :/64 -j DNPT --src-pfx 2001:e20:2000:40f::/64 --dst-pfx fd00::/64 IPv6 neighbor proxy を有効にする必要があるかもしれない。 sysctl -w net.ipv6.conf.all.proxy_ndp=1 また、変換されたフローに対するコネクション追跡を無効にするには NOTRACK ターゲットを使用す ... ... ィレクトリに対して設定をすると、 それ以降生成されるデバイス全てに対してその設定が用いられる。 特に指定がなければ、時間に関る sysctl の単位は秒である。 anycast_delay (Linux 2.2 以降) IPv6 の近傍要請メッセージ (neighbor soliciation message) に応答するまでの ... ... の新しい機能である。 関連項目 ip (7), raw (7), socket (7), udplite (7) The kernel source file Documentation/networking/ip-sysctl.txt . RFC 768 : User Datagram Protocol RFC 1122 : ホストの必要条件 RFC 1191 : path MTU discovery の記述 この文書について こ ... ... かった。 ( path_resolution (7) も参照すること。) EACCES Where O_CREAT is specified, the protected_fifos or protected_regular sysctl is enabled, the file already exists and is a FIFO or regular file, the owner of the file is neither the current user nor t ... ... かった。 ( path_resolution (7) も参照すること。) EACCES Where O_CREAT is specified, the protected_fifos or protected_regular sysctl is enabled, the file already exists and is a FIFO or regular file, the owner of the file is neither the current user nor t ... 日本語の文書やマニュアルを配布している個人/プロジェクトへのリンクです。