JM プロジェクトは、主に Linux 関連のマニュアルページの日本語ページを翻訳・公開しています。
... まず第一に、いろいろな場所に設定ファイルを置いて 読み込ませることができる。 アプリケーションは、デフォルトでは /usr/share/snmp, /usr/lib/snmp, $HOME/.snmp という順番で設定ファイルを探す。 これらのディレクトリ以下にある .conf と .local.conf という拡張 ... イルのタイプについて、 設定ファイルが存在できる 6 つのデフォルトの場所がある。 さらに上記のデフォルトの検索パスは、 環境変数 SNMPCONFPATH を設定して変更できる。 SNMPCONFPATH には、検索するディレクトリを ':' で区切ったリストで指定する。 そして永続的なデ ... ータを格納するアプリケーションは、 設定ファイルを /var/snmp でも検索する。 設定ファイルのタイプ 各アプリケーションは複数の設定ファイルを使うことができる。 これら設定ファイルでアプリケ ... ... お読みください パスフレーズのような注意を要する情報を格納する場合は、 これらの設定ファイルを読み込みだけにすること ! 初めに snmp_config (5) の man ページを読むこと。 この man ページでは、ucd-snmp 設定ファイルの 動作・置き場所・連携法などが説明されてい ... ストの mib ファイルを読み込んで解析する。 この値は環境変数 MIBFILES で上書きされる点に注意すること。 defaultPort port 全ての snmp アプリケーションとデモで使用する デフォルトのポート番号。 defVersion (v1|v2c|v3) デフォルトの snmp バージョン。 defCommuni ... ty string snmpv1 と snmpv2c のデフォルトのコミュニティ文字列。 defSecurityName string snmpv3 リクエストで使用するデフォルトの snmpv3 USM ... ... ジェントが mib エントリを操作したり表示したりするためには、 このファイルは必要ない。 最初にお読みください 最初に man ページ snmp_config (5) を読んでおくこと。 ここには ucd-snmp ファイルの操作法・場所・ 互いにどのように動作するかが書かれている。 さらに ... 、 snmpconf アプリケーション (perl スクリプト) にざっと目を通すのもよいかもしれない。 このアプリケーションはユーザーに情報を提示し ... て snmpd.conf ファイルの作成を助けてくれる。 試してみなさい。本当に。さあ、今すぐに。 snmpconf -g basic_setup で始められます。 拡張 ... ... 必要な訳ではない。 このファイルは trap デーモンに拡張性を提供するための手段として用いられる。 最初にお読みください 最初に、 snmp_config (5) の man ページを読んでおくこと。 この man ページには、ucd-snmp 設定ファイルの処理のされ方・ ファイルの場所・設定 ... raphandle OID|default PROGRAM [ARGS ...] traphandle 設定ディレクティブは、OID トークンにマッチする trap を受信したときに、 snmptrapd が起動する外部プログラムを設定する。 OID トークンが default の場合、他のトラップハンドラにマッチしない trap は、 この ... 白までの行の最初のトークンは OID で、 行の残りの部分はその値である。 1 番目の OID は system.sysUpTime.0、 2 番目の OID は ...snmpTrap.snmpTrapOID.0 にすべきである。 OID の残りは trap に含まれる variable bindings である (ただし最後の OID はこの限りでない ... ... に、各データ型の格納場所はアプリケーションレベルでも分割されている。 現在のところ 2 つの格納場所がある。 1 つ目の格納場所は、SNMP ライブラリ自身によって予約されている。 2 つ目の格納場所は、アプリケーションによって使われることを意図しており、 ライブラリ ... る */ /* 整数値を操作するライブラリで使われるもの */ #define DS_LIB_MIB_WARNINGS 0 #define DS_LIB_SECLEVEL 1 #define DS_LIB_SNMPVERSION 2 #define DS_LIB_DEFAULT_PORT 3 #define DS_LIB_PRINT_SUFFIX_ONLY 4 /* oid node == 1 のものを表示する。 1 番目と似て ... である。 ftype 変数は token キーワードを探すためのファイル名のベース文字列である。 例えば、 ds_register_config(ASN_INTEGER, "snmp", "testtoken", DS_APPLICATION_ID, 5) という呼び出しでは、snmp.conf ファイルが見つかってパースされるときに、 "testtoken" と ... ... ネットワーク化バージョンである。 このコマンドは、 HOST-RESOURCES-MIB の hrStorageTable または UCD-SNMP-MIB の dskTable を 調べて、リモートマシンのディスク使用量をチェックする。 デフォルトでは、一般により多くの情報が含まれる h ... rStorageTable が優先的に選ばれる。 しかし、-Cu 引き数を snmpdf に渡して、 強制的に dskTable を使わせることもできる。 snmpd.conf ファイルで disk ディレクティブを使って dskTable を設定す ... るには、 man ページ snmpd.conf (5) を参照すること。 関連項目 snmpd.conf (5), snmp.conf (5) ... ... 繰り返しを行わない入力変数の数を指定する。 rep は残りの変数の最大繰り返し回数である。 デフォルトは -B 0 100 である。 例えば snmpbulkwalk -v 2c -B 1 10 zeus public system interfaces では、変数 system.sysDescr.0 (辞書順で system の次のオブジェクト) と イ ... メッセージが表示される。 これは、リクエストがなぜ機能しなかったかを正確に示す助けとなる。 注意 名前が暗に示しているように、 snmpbulkget は SNMP v1 では使用できない SNMP GETBULK メッセージを使う。 関連項目 snmpcmd (1), variables (5). ... ... mpconf 説明 snmpconf は簡単な perl スクリプトで、 設定ファイルの設定を段階を踏んで簡単に行う。 かなり容易に使えるだろう。 実行して質問に答え ... ディレクトリに保存される。 特に便利なオプションは、 ユーザーに対して、指定した設定の質問を行う -g スイッチである。 例えば、 snmpconf -g basic_setup を実行せよ。 オプション -f もし望むならば、ユーザーにプロンプトを出さずに、 カレントディレクトリに既にあ ... 、グローバルシステムコマンドが探す場所に ファイルをインストールする。 -p 終了したときに、ユーザーのホームディレクトリにある .snmp サブディレクトリにファイルをインストールする。 -I DIRECTORY 終了したときに、ディレクトリ DIRECTORY にファイルをインストール ... ... [-c confFile] [-F FORMAT] 説明 snmptrapd はローカルマシンの SNMP-TRAP ポート (162) に送られてきた snmp trap メッセージを受信してログに記録する SNMP アプリケー ... ションである。 ログメッセージは以下のような形式である: Sep 17 22:39:52 suffern snmptrapd: 128.2.13.41: Cold Start Trap (0) Uptime: 8 days, 0:35:46 snmptrapd は UDP ポート 162 をオープンするので、 root で実行 ... しなければならない。 コマンドライン引き数 snmpcmd (1) で説明されているコマンドライン引き数に加え、以下の引き数が使用できる。 -P ログメッセージを標準エラーに表示する。 -o ... ... IBS 環境変数で定義されている mib ファイル (またはコンパイル時に定義されるデフォルトのリスト) に書かれている。 また DATADIR/snmp/mibs ディレクトリ (または MIBDIRS 環境変数) にある mib ファイルにも書かれている。 関連項目 RFC 1065, RFC 1066, RFC 1067, I ... 日本語の文書やマニュアルを配布している個人/プロジェクトへのリンクです。