JM プロジェクトは、主に Linux 関連のマニュアルページの日本語ページを翻訳・公開しています。
... す。 使用例 named-bootconf < named.boot > named.conf バグ ソースファイル中のコメントが 出力ファイル中の正しい位置に現れないことがあります。 ... 関連項目 named (8), named.conf5 ... ... p_name ] [- t directory ] [- w directory ] [ config_file ] 解説 named はインターネットドメインネームサーバです。 インターネットドメインネームシステムの詳細な情報については RFC 1033, 1034, 1035 ... を参照してください。 パラメータがない場合は named はデフォルトの設定ファイルである /etc/namedb/named.conf の初期化データを読み込み、問い合わせに対し待機します。 コマンド行の ... 最後に与えられた config_file 引数は ``- b '' または ``- c '' フラグを使用して指定された config_file を無効にします。 注: named のいくつかのオプションと多くの動作は、設定ファイルの中で 制御できます。更なる情報はこの BIND 配布物に含まれる設定ファイルガ ... ... i ixfr_file ] [- t trace_file ] [- p port# ] [- S ] nameserver [ [ axfr ] | [ ixfr ] 解説 named-xfer は、 named (8) によって実行される補助プログラムです。 インターネットネームサーバから呼び出されて、ゾーン情報を受け取り ... 返す値になります。 -S SOA レコードと NS レコードの転送のみを許可し、 ゾーンに対して A レコードを結合します。 SOA レコードは named (8) によって読み込まれませんが、 NS レコードをいつ検証するのかを決定するのに使用されます。 詳しくは named (8) の `` stubs ... 指定します。 全ゾーン転送には axfr を使用し、インクリメンタルゾーン転送には ixfr を使用してください。 関連項目 hostname (7), named (8), resolver (3), resolver (5), RFC 882, RFC 883, RFC 973, RFC 974, RFC 1033, RFC 1034, RFC 1035, RFC 1123, RFC 1995 ``Na ... ... 、何であれ次のステートメントの先頭だと 解釈されてしまいます。 BIND 4.9.x から変更する BIND 4.9.x の設定ファイルは、 src/bin/named/named-bootconf という名前の、BIND 8.2.x のソースキットに同梱されている シェルスクリプトを使用することで新しいフォーマットに ... だけで区切られた、 1 つまたはそれ以上の数の 0 から 255 までの整数です。 例えば、 123 45.67 89.123.45.67 などです。 domain_name DNS 名として使用される文字列をクォーテーションで囲んだものです。 例えば、 Qq Li my.test.domain のようにです。 path_name パス ... 作でのアクセス制御を決定するために使われます。 また、アドレスマッチリストは、他のネームサーバに問い合わせる際の優先順位や、 named が問い合わせを待つアドレスを決定するためにも使われます。 アドレスマッチリストを構成する要素は、次のうちのどれでもありえます ... ... d の集合は、 シグナルによるインタフェースを使用した場合の方が狭いことに注意してください。 おそらく pidfile 引数は /var/run/named.pid のようなものです。 -d デバッグ出力を有効にします。主に開発者が興味を持つものです。 -q プロンプトと結果のテキスト出力を ... 能を切り替えます (前述の - s の記述を参照)。 注釈 pidfile モードで実行すると、 start と restart のコマンドへの引数は、新しい named に対するコマンドラインとして渡されます。 channel モードで実行すると、 start コマンドは無く、 restart コマンドは単にネームサ ... ーバに対して自己を execvp (2) するよう通知します。 作者 Paul Vixie (Internet Software Consortium) 関連項目 named (8) ... ... 実行されるという順番で、原子的に処理されます。 nsupdate は次のような入力レコードの書式を理解します。 prereq nxdomain domain-name domain-name で指定したドメイン内に、どのような RR もないことを要求します。 prereq yxdomain domain-name domain-name で指定し ... www.example.com CNAME > update add www.example.com 3600 CNAME test.example.com > この例では、nsupdate はディレクトリ "/var/named/keys" に存在するキー "mykey" で署名されます。 $ nsupdate -k /var/named/keys:mykey > update add ftp.example.com 60 A 192.16 ... 答フィールドを確認するしかありません。 関連ファイル /etc/resolv.conf ドメイン名とネームサーバのアドレスの初期設定。 関連項目 named (8), resolver (3), resolver (5); RFC-1034, ``Domain Names - Concepts and Facilities'' RFC-1035, ``Domain Names - Implement ... ... binary data that was assigned using setxattr (2). If size is specified as zero, these calls return the current size of the named extended attribute (and leave value unchanged). This can be used to determine the size of the buffer that should be suppli ... retrieved. This can happen on filesystems that support very large attribute values such as NFSv4, for example. ENODATA The named attribute does not exist, or the process has no access to this attribute. ENOTSUP 拡張属性がそのファイルシステムでサポート ... ... binary data that was assigned using setxattr (2). If size is specified as zero, these calls return the current size of the named extended attribute (and leave value unchanged). This can be used to determine the size of the buffer that should be suppli ... retrieved. This can happen on filesystems that support very large attribute values such as NFSv4, for example. ENODATA The named attribute does not exist, or the process has no access to this attribute. ENOTSUP 拡張属性がそのファイルシステムでサポート ... ... binary data that was assigned using setxattr (2). If size is specified as zero, these calls return the current size of the named extended attribute (and leave value unchanged). This can be used to determine the size of the buffer that should be suppli ... retrieved. This can happen on filesystems that support very large attribute values such as NFSv4, for example. ENODATA The named attribute does not exist, or the process has no access to this attribute. ENOTSUP 拡張属性がそのファイルシステムでサポート ... ... ize from that used by the C library. In this manual page, the former is referred to as kernel_sigset_t (it is nevertheless named sigset_t in the kernel sources). The glibc wrapper function for sigprocmask () silently ignores attempts to block the two ... hat are used internally by the NPTL threading implementation. See nptl (7) for details. The original Linux system call was named sigprocmask (). However, with the addition of real-time signals in Linux 2.2, the fixed-size, 32-bit sigset_t (referred to ... 日本語の文書やマニュアルを配布している個人/プロジェクトへのリンクです。