JM プロジェクトは、主に Linux 関連のマニュアルページの日本語ページを翻訳・公開しています。
... lude < netdb.h > int getaddrinfo(const char * node , const char * service , const struct addrinfo * hints , struct addrinfo ** res ); void freeaddrinfo(str ... ddrinfo * res ); const char *gai_strerror(int errcode ); glibc 向けの機能検査マクロの要件 ( feature_test_macros (7) 参照): getaddrinfo (), freeaddrinfo (), gai_strerror (): Since glibc 2.22: _POSIX_C_SOURCE >= 200112L Glibc 2.21 and earlier: _POSIX_C_SOURCE ... 説明 getaddrinfo () は、(インターネットのホストとサービスを識別する) node と service を渡すと、一つ以上の addrinfo 構造体を返す。それぞれの ... ... lude < netdb.h > int getaddrinfo(const char * node , const char * service , const struct addrinfo * hints , struct addrinfo ** res ); void freeaddrinfo(str ... ddrinfo * res ); const char *gai_strerror(int errcode ); glibc 向けの機能検査マクロの要件 ( feature_test_macros (7) 参照): getaddrinfo (), freeaddrinfo (), gai_strerror (): Since glibc 2.22: _POSIX_C_SOURCE >= 200112L Glibc 2.21 and earlier: _POSIX_C_SOURCE ... 説明 getaddrinfo () は、(インターネットのホストとサービスを識別する) node と service を渡すと、一つ以上の addrinfo 構造体を返す。それぞれの ... ... lude < netdb.h > int getaddrinfo(const char * node , const char * service , const struct addrinfo * hints , struct addrinfo ** res ); void freeaddrinfo(str ... ddrinfo * res ); const char *gai_strerror(int errcode ); glibc 向けの機能検査マクロの要件 ( feature_test_macros (7) 参照): getaddrinfo (), freeaddrinfo (), gai_strerror (): Since glibc 2.22: _POSIX_C_SOURCE >= 200112L Glibc 2.21 and earlier: _POSIX_C_SOURCE ... 説明 getaddrinfo () は、(インターネットのホストとサービスを識別する) node と service を渡すと、一つ以上の addrinfo 構造体を返す。それぞれの ... ... s (7) 参照 */ #include < netdb.h > int getaddrinfo_a(int mode , struct gaicb * list[] , int nitems , struct sigevent * sevp ); int gai_suspend(const struct gaicb * const lis ... t timespec * timeout ); int gai_error(struct gaicb * req ); int gai_cancel(struct gaicb * req ); -lanl でリンクする。 説明 getaddrinfo_a () 関数は getaddrinfo (3) と同じ処理を実行するが、 複数の名前検索を非同期で実行でき、 検索処理の完了の通知ができる点が異 ... har *ar_name; const char *ar_service; const struct addrinfo *ar_request; struct addrinfo *ar_result; }; この構造体の要素は getaddrinfo (3) の引数に対応している。 したがって、 ar_name はインターネットホストを示す node 引数に、 ar_service はサービスを示す ser ... ... s (7) 参照 */ #include < netdb.h > int getaddrinfo_a(int mode , struct gaicb * list[] , int nitems , struct sigevent * sevp ); int gai_suspend(const struct gaicb * const lis ... t timespec * timeout ); int gai_error(struct gaicb * req ); int gai_cancel(struct gaicb * req ); -lanl でリンクする。 説明 getaddrinfo_a () 関数は getaddrinfo (3) と同じ処理を実行するが、 複数の名前検索を非同期で実行でき、 検索処理の完了の通知ができる点が異 ... har *ar_name; const char *ar_service; const struct addrinfo *ar_request; struct addrinfo *ar_result; }; この構造体の要素は getaddrinfo (3) の引数に対応している。 したがって、 ar_name はインターネットホストを示す node 引数に、 ar_service はサービスを示す ser ... ... s (7) 参照 */ #include < netdb.h > int getaddrinfo_a(int mode , struct gaicb * list[] , int nitems , struct sigevent * sevp ); int gai_suspend(const struct gaicb * const lis ... t timespec * timeout ); int gai_error(struct gaicb * req ); int gai_cancel(struct gaicb * req ); -lanl でリンクする。 説明 getaddrinfo_a () 関数は getaddrinfo (3) と同じ処理を実行するが、 複数の名前検索を非同期で実行でき、 検索処理の完了の通知ができる点が異 ... har *ar_name; const char *ar_service; const struct addrinfo *ar_request; struct addrinfo *ar_result; }; この構造体の要素は getaddrinfo (3) の引数に対応している。 したがって、 ar_name はインターネットホストを示す node 引数に、 ar_service はサービスを示す ser ... ... s (7) 参照 */ #include < netdb.h > int getaddrinfo_a(int mode , struct gaicb * list[] , int nitems , struct sigevent * sevp ); int gai_suspend(const struct gaicb * const lis ... t timespec * timeout ); int gai_error(struct gaicb * req ); int gai_cancel(struct gaicb * req ); -lanl でリンクする。 説明 getaddrinfo_a () 関数は getaddrinfo (3) と同じ処理を実行するが、 複数の名前検索を非同期で実行でき、 検索処理の完了の通知ができる点が異 ... har *ar_name; const char *ar_service; const struct addrinfo *ar_request; struct addrinfo *ar_result; }; この構造体の要素は getaddrinfo (3) の引数に対応している。 したがって、 ar_name はインターネットホストを示す node 引数に、 ar_service はサービスを示す ser ... ... precedence ::1/128 50 precedence ::/0 40 precedence 2002::/16 30 precedence ::/96 20 precedence ::ffff:0:0/96 10 関連項目 getaddrinfo (3), RFC 3484 この文書について この man ページは Linux man-pages プロジェクトのリリース 5.10 の一部である。プロジェクトの説 ... ... hosts を使うのと全く同じです。 key 引数が一つ以上指定された場合は、それぞれの key についてアドレスファミリー AF_UNSPEC で getaddrinfo (3) を呼び出し、返された各々のソケットアドレス構造体を列挙します。 ahostsv4 ahosts と同じですが、 アドレスファミリーとして ... AF_INET を使用します。 ahostsv6 ahosts と同じですが、 アドレスファミリーとして AF_INET6 を使用します。この場合の getaddrinfo (3) の呼び出しでは AI_V4MAPPED も指定されます。 aliases key が指定されなかった場合、 setaliasent (3), getaliasent (3), end ... ョンは複数回使用可能ですが、各データベースに対しては最後のサービスのみが使われます (glibc 2.4 以降)。 -i , --no-idn ahosts / getaddrinfo (3) への検索で IDN エンコードを無効にします (glibc-2.13 以降)。 -? , --help 簡単な使用法を表示して終了します。 --usage 短い ... ... バのプログラムでは一般的に使用され、使用する際には名前からアドレスに変換しなければならない (一般的にはアドレスへの変換処理は getaddrinfo (3) か (廃止予定の) gethostbyname (3) で行われる)。 Hostnames are resolved by the NSS framework in glibc according to the ... l domain. The search path can be changed from the default by a system-wide configuration file (see resolver (5)). 関連項目 getaddrinfo (3), gethostbyname (3), nsswitch.conf (5), resolver (5), mailaddr (7), named (8) IETF RFC 1123 IETF RFC 1178 この文書につい ... 日本語の文書やマニュアルを配布している個人/プロジェクトへのリンクです。