JM プロジェクトは、主に Linux 関連のマニュアルページの日本語ページを翻訳・公開しています。
... 両方指定した場合、 pppoe が接続を初期化するためには、 両方に マッチする必要がある。 -U このオプションを指定すると、 pppoe は discovery パケット中の Host-Uniq タグを使う。 これを用いると複数の pppoe デーモンを起動し、 それぞれの discovery パケットが混信しない ... oe のプロセス ID を取得したり kill したりするのに使うことができる。 -e sess:mac このオプションを指定すると、 pppoe は発見 (discovery) の段階を省略して、セッションの段階に移る。 セッションは sess で指定され、 接続先の MAC アドレスは mac で指定される。 この ... 常の使用を意図したもの ではない 。 これは pppoe-server (8) のために設計されている。 -n このオプションを指定すると、 pppoe は discovery ソケットをオープンしない。 このモードは通常の使用を意図したもの ではない 。 これは pppoe-server (8) のために設計されている ... ... kopt (2) and can be employed only when the socket has been connected. IP_MTU_DISCOVER (Linux 2.2 以降) ソケットの Path MTU Discovery の設定をセット・取得する。 有効になっていると、Linux は SOCK_STREAM ソケットに対して RFC 1191 で定義されている Path MTU Di ... net/ipv4/ip_no_pmtu_disc ファイルに、0 ( IP_PMTUDISC_WANT ) か 0 以外 ( IP_PMTUDISC_DONT ) を書き込むことで行う。 Path MTU discovery 値 意味 IP_PMTUDISC_WANT ルートごとの設定を用いる。 IP_PMTUDISC_DONT Path MTU Discovery を行わない。 IP_PMTUDISC_DO 常に P ... ath MTU Discovery を行う。 IP_PMTUDISC_PROBE DFビットをセットするが、Path MTU を無視する。 path MTU discovery が有効になっていると、カーネル ... ... 取ることができた --- Linux 2.2 以降では、このオプションはもはや効力を持たない。 注意 デフォルトでは、raw ソケットは Path MTU Discovery を行う。 つまり、カーネルは特定の宛先 IP アドレスの MTU (Maximum Transmission Unit; 最大転送単位) を記録し、raw パケットの ... 小さくすべきである。 ソケットオプション IP_MTU_DISCOVER または /proc/sys/net/ipv4/ip_no_pmtu_disc ファイルを使って Path MTU Discovery を無効にすることもできる (詳細は ip (7) を参照)。 Path MTU Discovery を無効にした場合は、パケットサイズが インターフェース ... MTU よりも大きいと raw ソケットはそのパケットを フラグメント化して送出する。 しかしながら、性能と信頼性の理由から Path MTU Discovery を 無効にするのは推奨できない。 bind (2) システムコールを用いると、 raw ソケットを 特定のローカルアドレスにバインドさせるこ ... ... レスから 参照できなければならない。パケットはそのインターフェースにしか送られない。 デフォルトでは、Linux の UDP は Path MTU Discovery を行う。 つまり、カーネルは特定の宛先 IP アドレスの MTU (Maximum Transmission Unit; 最大転送単位) を記録し、UDP パケットの ... 小さくすべきである。 ソケットオプション IP_MTU_DISCOVER または /proc/sys/net/ipv4/ip_no_pmtu_disc ファイルを使って Path MTU Discovery を無効にすることもできる (詳細は ip (7) を参照)。 Path MTU Discovery を無効にした場合は、パケットサイズが インターフェース ... の MTU よりも大きいと UDP はそのパケットを フラグメント化して送出する。 しかしながら、性能と信頼性の理由から Path MTU Discovery を 無効にするのは推奨できない。 アドレスのフォーマット UDP は IPv4 の sockaddr_in アドレスフォーマットを用いる。これは ip ... ... 間サーバーであり、Linux やその他の UNIX 系システムで利用できる。 pppoe-server は pppoe クライアントと関連して動作し、 PPPoE discovery パケットに応答して、PPPoE セッションを設定する。 オプション -F -F オプションを指定すると、 pppoe-server は fork されずデー ... バーを稼働することができる。 ただし、セッション番号が重複しないように注意すること。 -f disc:sess -f オプションは、 PPPoE の discovery フレームと session フレームで使う イーサーネットフレームタイプを設定する。 タイプはコロンで区切られた 16 進数で指定する。 ... 。 -h -h オプションを指定すると、 使用法についての簡単なメッセージを表示して終了する。 動作 pppoe-server は入ってくる PPPoE discovery パケットを待ち受ける。 セッションが確立されると、サーバーは pppd プロセスを生成する。 以下のオプションが pppd に渡される: ... ... [ , uint16 ... ] ; 本オプションは、MTU サイズの表を指定します。 この表は、 RFC 1191 で定義される、パス MTU 発見 (Path MTU Discovery) 実施時に使用します。 表の書式は、最小から最大への順の、 16 ビット符号無し整数のリストです。 最小 MTU は 68 以上であること ... を指定します。 正当なブロードキャストアドレスの値は、 STD 3 (RFC1122) の 3.2.1.3 節に記述されています。 option perform-mask-discovery flag ; 本オプションは、 クライアントが ICMP を使用してサブネットマスク発見を実施すべきかを指定します。 値 0 は、クライアン ... は、クライアントが応答すべきでないことを意味します。 値 1 は、クライアントが応答すべきであることを意味します。 option router-discovery flag ; 本オプションは、 RFC 1256 で定義されるルータ発見 (Router Discovery) 機構を使用して ルータを請求すべきかを指定します ... ... を返す。 setsockopt (): そのソケットに対して用いる MTU の値を設定する。 MTU の大きさは、 そのデバイスの MTU または (Path MTU Discovery が可能なら) その経路の MTU の大きさ以下でなければならない。 引数は整数へのポインター。 IPV6_MTU_DISCOVER そのソケットでの ... Path MTU Discovery を制御する。 詳細は ip (7) の IP_MTU_DISCOVER を参照。 IPV6_MULTICAST_HOPS そのソケットでの multicast の hop 数の上限値を設 ... ... able packet) を送る最大レート。 これは特定のルートまたは行き先にパケットを送信するレートを制限する。 この制限は、 path MTU discovery に必要な ICMP_FRAG_NEEDED パケットの送信には影響しない。 icmp_echo_ignore_all (Linux 2.2 以降) この値が非ゼロの場合は、 Li ... ... で共通の機能を一緒に説明している。 関連項目 capabilities (7), ip (7), arpd (8) RFC 826: ARP の説明。 RFC 2461: IPv6 neighbor discovery の説明と利用されている基礎アルゴリズム。 Linux 2.2 以降では IPv4 ARP は可能な場合は IPv6 アルゴリズムを使っている。 この文 ... ... 0 を指定すると一切予約領域を取らない。 tcp_base_mss (Integer; default: 512; Linux 2.6.17 以降) パケット化レイヤの Path MTU discovery (MTU probing) で、 search_low の初期値と使用される値。 MTU probing が有効な場合、この値はその接続の MSS の初期値となる。 t ... 優先される。 tcp_mtu_probing (integer; default: 0; Linux 2.6.17 以降) このパラメーターは、TCP のパケット化レイヤの Path MTU discovery を制御する。 このファイルには以下の値を設定できる。 0 無効にする。 1 デフォルトでは無効だが、ICMP ブラックホールが検出され ... 日本語の文書やマニュアルを配布している個人/プロジェクトへのリンクです。