JM プロジェクトは、主に Linux 関連のマニュアルページの日本語ページを翻訳・公開しています。
... いうと、subnet-mask オプション文は、 subnet 文で宣言されたサブネットマスクより優先されるからです。 range 文 range [ dynamic-bootp ] low-address [ high-address ] ; 動的に割り当てられるアドレスを含むサブネットでは、 少なくとも range 文を一つ指定しなければ ... レスのすべては、 range 文が宣言されたサブネットの中に入っている必要があります。 指定した範囲のアドレスを DHCP クライアントと BOOTP クライアントの両方に割り当てて良い場合は、 dynamic-bootp フラグを指定します。 アドレス 1 つだけを割り当てる場合は、 high-a ... ddress は省略できます。 host 文 host hostname { [ parameters ] [ declarations ] } サービス対象となる BOOTP クライアントには、それぞれ host が最低ひとつづつ必要になります。 DHCP クライアントに対しても host 文は指定できますが、 素性 ... ... oftware Consortium DHCP サーバである dhcpd は、 Dynamic Host Configuration Protocol (DHCP) と Internet Bootstrap Protocol (BOOTP) とを実装したものである。 DHCP を用いると、 TCP/IP ネットワーク上のホストは IP アドレスを要求して割り当ててもらうことができ ... 、 また接続したネットワークの情報を取得できます。 BOOTP も同様の機能を持っていますが、少々制限があります。 動作 DHCP プロトコルは、ネットワーク管理者が知らないホストに対して、 予 ... いて、 そこにはすべての貸し出し情報が残っているはずです。 従って特殊なクラッシュリカバリ処理は必要ありません。 このサーバは BOOTP もサポートしています。 DHCP とは異なり、 BOOTP プロトコルは動的に割り当てられたアドレスが不要になったとき、 それを復帰させ ... ... nsortium の DHCP クライアントである dhclient は動的ホスト設定プロトコル (DHCP: Dynamic Host Configuration Protocol) または BOOTP プロトコルを用いて、あるいは これらのプロトコルが失敗した場合にはアドレスを静的に割り当てて、 1 つ以上のネットワークインタ ... リースが有効であるか検証し、 有効であれば次に再起動されるまでそのリースを使います。 また移動ホストは、DHCP は利用できないが BOOTP なら利用できるような ネットワークへ移動することもあるでしょう。 そのような場合は、古いリースを順次試すよりも、 そのネットワ ... ークの管理者と相談して BOOTP データベースにエントリを作成してもらい、 そのネットワーク上で素早くブートできるようにするとよいでしょう。 コマンドライン d ... ... Software Consortium DHCP 中継エージェント dhcrelay は、 DHCP サーバが直接には接続されていないサブネットからの DHCP 要求や BOOTP 要求を、他のサブネットにある 1 つまたは複数の DHCP サーバに中継する手段を提供します。 動作 この DHCP 中継エージェントは、 ... す。 これはシステムの起動スクリプトなどでは邪魔かもしれません。 この動作を無効にするには -q フラグを指定します。 DHCP 要求や BOOTP 要求の転送先となる DHCP サーバの名前は、 少なくとも 1 つ以上コマンドラインで指定しなければなりません。 関連項目 dhclient ( ... ... ないリースを順に調べ、そこに挙がっている ルータに ping を行って、それが利用可能なリースかどうかを調べます。 DHCP サービスや BOOTP サービスが存在しないネットワークのために、 1 つ以上の 固定 リースをクライアント設定ファイルに定義しておいて、 クライアント ... スキーワード、左中括弧、1 つ以上のリース宣言文、 右中括弧が続いたもので構成されます。 リース宣言として、次のものが可能です: bootp; bootp 文は、リースが DHCP プロトコルではなく、 BOOTP プロトコルを用いて取得されたことを示します。 この文をクライアント設定 ... ... スの名前で置き換えられる。 関連項目 Dynamic Host Configuration Protocol, RFC2131 および RFC1541 (obsolete) DHCP Options and BOOTP Vendor Extensions, RFC2132 バグ dhcpcd は貸し出しの終了期限を計算するのに time (3) を用いる。クライアントの実行中にシステム ... ... me string ; 本オプションは TFTP サーバを指定し、 クライアントがサポートする場合には server-name 宣言と同じ効果を持ちます。 BOOTP クライアントは、本オプションをサポートしないでしょう。 DHCP クライアントによってはサポートしているものがあり、 実際必須とし ... 日本語の文書やマニュアルを配布している個人/プロジェクトへのリンクです。