JM プロジェクトは、主に Linux 関連のマニュアルページの日本語ページを翻訳・公開しています。
... ョンを宣言する文法、 そして宣言可能なオプションの名前と書式を、ここに文書化しています。 リファレンス: オプション文 常に DHCP option 文は、 キーワード option で開始し、単一のオプション名が続き、 オプションデータが続きます。 オプションの名前とデータの書式は ... NVT ASCII 文字列を指定します。 文字列はダブルクォートで括る必要があります。 例えば domain-name オプションを指定する文法は option domain-name "isc.org"; となります。 flag データタイプはブール値を指定します。 ブール値は真または偽のいずれかです (オンまた ... NVT ASCII 文字列か、 コロン区切りで 16 進数で指定されるオクテットの連続のいずれかを指定します。 例えば次のようになります: option dhcp-client-identifier "CLIENT-FOO"; または option dhcp-client-identifier 43:4c:49:45:54:2d:46:4f:4f; 次に示す様々なオプシ ... ... rr , optopt ; #include < getopt.h > int getopt_long(int argc , char * const argv[] , const char * optstring , const struct option * longopts , int * longindex ); int getopt_long_only(int argc , char * const argv[] , const char * optstring , const struc ... t option * longopts , int * longindex ); glibc 向けの機能検査マクロの要件 ( feature_test_macros (7) 参照): getopt (): _POSIX_C_SOUR ... された引数の個数と配列である。 argv の要素のうち '-' で始まるもの (かつ "-" 単独や "--" 単独ではないもの) は オプション要素 (option element) とみなされる。 この要素から先頭の '-' を除いた文字は オプション文字 (option character) とされる。 getopt () は、繰 ... ... rr , optopt ; #include < getopt.h > int getopt_long(int argc , char * const argv[] , const char * optstring , const struct option * longopts , int * longindex ); int getopt_long_only(int argc , char * const argv[] , const char * optstring , const struc ... t option * longopts , int * longindex ); glibc 向けの機能検査マクロの要件 ( feature_test_macros (7) 参照): getopt (): _POSIX_C_SOUR ... された引数の個数と配列である。 argv の要素のうち '-' で始まるもの (かつ "-" 単独や "--" 単独ではないもの) は オプション要素 (option element) とみなされる。 この要素から先頭の '-' を除いた文字は オプション文字 (option character) とされる。 getopt () は、繰 ... ... rr , optopt ; #include < getopt.h > int getopt_long(int argc , char * const argv[] , const char * optstring , const struct option * longopts , int * longindex ); int getopt_long_only(int argc , char * const argv[] , const char * optstring , const struc ... t option * longopts , int * longindex ); glibc 向けの機能検査マクロの要件 ( feature_test_macros (7) 参照): getopt (): _POSIX_C_SOUR ... された引数の個数と配列である。 argv の要素のうち '-' で始まるもの (かつ "-" 単独や "--" 単独ではないもの) は オプション要素 (option element) とみなされる。 この要素から先頭の '-' を除いた文字は オプション文字 (option character) とされる。 getopt () は、繰 ... ... rr , optopt ; #include < getopt.h > int getopt_long(int argc , char * const argv[] , const char * optstring , const struct option * longopts , int * longindex ); int getopt_long_only(int argc , char * const argv[] , const char * optstring , const struc ... t option * longopts , int * longindex ); glibc 向けの機能検査マクロの要件 ( feature_test_macros (7) 参照): getopt (): _POSIX_C_SOUR ... された引数の個数と配列である。 argv の要素のうち '-' で始まるもの (かつ "-" 単独や "--" 単独ではないもの) は オプション要素 (option element) とみなされる。 この要素から先頭の '-' を除いた文字は オプション文字 (option character) とされる。 getopt () は、繰 ... ... rr , optopt ; #include < getopt.h > int getopt_long(int argc , char * const argv[] , const char * optstring , const struct option * longopts , int * longindex ); int getopt_long_only(int argc , char * const argv[] , const char * optstring , const struc ... t option * longopts , int * longindex ); glibc 向けの機能検査マクロの要件 ( feature_test_macros (7) 参照): getopt (): _POSIX_C_SOUR ... された引数の個数と配列である。 argv の要素のうち '-' で始まるもの (かつ "-" 単独や "--" 単独ではないもの) は オプション要素 (option element) とみなされる。 この要素から先頭の '-' を除いた文字は オプション文字 (option character) とされる。 getopt () は、繰 ... ... rr , optopt ; #include < getopt.h > int getopt_long(int argc , char * const argv[] , const char * optstring , const struct option * longopts , int * longindex ); int getopt_long_only(int argc , char * const argv[] , const char * optstring , const struc ... t option * longopts , int * longindex ); glibc 向けの機能検査マクロの要件 ( feature_test_macros (7) 参照): getopt (): _POSIX_C_SOUR ... された引数の個数と配列である。 argv の要素のうち '-' で始まるもの (かつ "-" 単独や "--" 単独ではないもの) は オプション要素 (option element) とみなされる。 この要素から先頭の '-' を除いた文字は オプション文字 (option character) とされる。 getopt () は、繰 ... ... rr , optopt ; #include < getopt.h > int getopt_long(int argc , char * const argv[] , const char * optstring , const struct option * longopts , int * longindex ); int getopt_long_only(int argc , char * const argv[] , const char * optstring , const struc ... t option * longopts , int * longindex ); glibc 向けの機能検査マクロの要件 ( feature_test_macros (7) 参照): getopt (): _POSIX_C_SOUR ... された引数の個数と配列である。 argv の要素のうち '-' で始まるもの (かつ "-" 単独や "--" 単独ではないもの) は オプション要素 (option element) とみなされる。 この要素から先頭の '-' を除いた文字は オプション文字 (option character) とされる。 getopt () は、繰 ... ... き動作の文法をここに示します。 参照: 条件付き動作 条件付き動作は、if, else, elsif 文を使用して指定します。 条件文は、通常文 (option 文) が登場可能な場所はどこにでも登場可能であり、 またこのような文を括ることも可能です。 サーバにおける条件文は次のようにな ... ることが多いでしょう: if option dhcp-user-class = "accounting" { max-lease-time 17600; option domain-name "accounting.example.org"; option domain-name-ser ... vers ns1.accounting.example.org, ns2.accounting.example.org; } elsif option dhcp-user-class = "sales" { max-lease-time 17600; option domain-name "sales.example.org"; option domain-name-servers ns1.s ... ... lnetd にデバッグ情報を表示させ、 telnetd の動作をユーザが見ることができる。 以下に示すような、いくつかの debugmode がある: options telnet オプションのネゴシエーションについての情報が表示される。 report options で表示される情報に加えて、 どのような操作が ... rvices /etc/issue.net 関連項目 telnet (1), login (1), issue.net5 準拠 RFC-854 TELNET PROTOCOL SPECIFICATION RFC-855 TELNET OPTION SPECIFICATIONS RFC-856 TELNET BINARY TRANSMISSION RFC-857 TELNET ECHO OPTION RFC-858 TELNET SUPPRESS GO AHEAD OPTION RFC-8 ... 59 TELNET STATUS OPTION RFC-860 TELNET TIMING MARK OPTION RFC-861 TELNET EXTENDED OPTIONS - LIST OPTION RFC-885 TELNET END OF RECORD OPTION RFC-10 ... 日本語の文書やマニュアルを配布している個人/プロジェクトへのリンクです。