JM プロジェクトは、主に Linux 関連のマニュアルページの日本語ページを翻訳・公開しています。
... ソケットタイプ のエントリは、 ``stream'' ``dgram'' ``raw'' ``rdm'' ``seqpacket'' のいずれかで、それぞれソケットが stream, datagram, raw, reliably delivered message, sequenced packet socket である場合に対応している。 プロトコル のエントリには、 /etc/prot ... ``udp'' などである。 RPC ベースのサービスの場合、 ``rpc/tcp'' や ``rpc/udp '' のような指定になる。 wait/nowait エントリは、datagram ソケットにのみ適用できる (その他のソケットでは、この場所は ``nowait'' でなければならない)。 もし datagram サーバーが相手に ... このようなサーバーは ``マルチスレッド'' サーバーと呼ばれ、 ``nowait'' エントリを指定しなければならない。 入って来る全ての datagram を処理し、 時間切れまで動作する datagram サーバーは、 ``シングルスレッド'' サーバーと呼ばれ、 ``wait'' エントリを指定しなけ ... ... サポートしている。 Valid socket types in the UNIX domain are: SOCK_STREAM , for a stream-oriented socket; SOCK_DGRAM , for a datagram-oriented socket that preserves message boundaries (as on most UNIX implementations, UNIX domain datagram sockets are alway ... s reliable and don't reorder datagrams); and (since Linux 2.6.4) SOCK_SEQPACKET , for a sequenced-packet socket that is connection-oriented, preserves message b ... the socket is created. On Linux, connecting to a stream socket object requires write permission on that socket; sending a datagram to a datagram socket likewise requires write permission on that socket. POSIX does not make any statement about the effect ... ... う一度受信コールを呼び出すと、同じデータが返ることになる。 MSG_TRUNC (Linux 2.2 以降) raw ソケット ( AF_PACKET )、 Internet datagram ソケット (Linux 2.4.27/2.6.8 以降)、 netlink (Linux 2.6.22 以降) ソケット、 UNIX datagram ソケット (Linux 3.4 以降) の場合 ... disconnect occurs, or the next data to be received is of a different type than that returned. This flag has no effect for datagram sockets. recvfrom() recvfrom () は受信したメッセージをバッファー buf に格納する。 呼び出し元はバッファーサイズを len で指定 ... BSD で初めて実装された) POSIX.1 では、 MSG_OOB , MSG_PEEK , MSG_WAITALL フラグだけが記載されている。 注意 If a zero-length datagram is pending, read (2) and recv () with a flags argument of zero provide different behavior. In this circumstance, read (2) ... ... う一度受信コールを呼び出すと、同じデータが返ることになる。 MSG_TRUNC (Linux 2.2 以降) raw ソケット ( AF_PACKET )、 Internet datagram ソケット (Linux 2.4.27/2.6.8 以降)、 netlink (Linux 2.6.22 以降) ソケット、 UNIX datagram ソケット (Linux 3.4 以降) の場合 ... disconnect occurs, or the next data to be received is of a different type than that returned. This flag has no effect for datagram sockets. recvfrom() recvfrom () は受信したメッセージをバッファー buf に格納する。 呼び出し元はバッファーサイズを len で指定 ... BSD で初めて実装された) POSIX.1 では、 MSG_OOB , MSG_PEEK , MSG_WAITALL フラグだけが記載されている。 注意 If a zero-length datagram is pending, read (2) and recv () with a flags argument of zero provide different behavior. In this circumstance, read (2) ... ... う一度受信コールを呼び出すと、同じデータが返ることになる。 MSG_TRUNC (Linux 2.2 以降) raw ソケット ( AF_PACKET )、 Internet datagram ソケット (Linux 2.4.27/2.6.8 以降)、 netlink (Linux 2.6.22 以降) ソケット、 UNIX datagram ソケット (Linux 3.4 以降) の場合 ... disconnect occurs, or the next data to be received is of a different type than that returned. This flag has no effect for datagram sockets. recvfrom() recvfrom () は受信したメッセージをバッファー buf に格納する。 呼び出し元はバッファーサイズを len で指定 ... BSD で初めて実装された) POSIX.1 では、 MSG_OOB , MSG_PEEK , MSG_WAITALL フラグだけが記載されている。 注意 If a zero-length datagram is pending, read (2) and recv () with a flags argument of zero provide different behavior. In this circumstance, read (2) ... ... 3828 に書かれている軽量なユーザーデータグラムプロトコル (Lightweight User Datagram Protocol; UDP-Lite) の実装である。 UDP-Lite は UDP (RFC 768) の拡張で、可変長のチェックサムをサポートしている。 このプロト ... ND_CSCOV 10 #define UDPLITE_RECV_CSCOV 11 関連項目 ip (7), ipv6 (7), socket (7), udp (7) RFC 3828 for the Lightweight User Datagram Protocol (UDP-Lite). Linux カーネルソース内の Documentation/networking/udplite.txt この文書について この man ページは Linu ... ... me protocol sockets (e.g., UNIX domain stream sockets) may successfully connect () only once. Some protocol sockets (e.g., datagram sockets in the UNIX and Internet domains) may use connect () multiple times to change their association. Some protocol soc ... kets (e.g., TCP sockets as well as datagram sockets in the UNIX and Internet domains) may dissolve the association by connecting to an address with the sa_family memb ... ... コル (Datagram Delivery Protocol, DDP) の 上位層のプロトコルの集合で、AppleTalk アドレスフォーマットを使う。 AppleTalk ファミリーは SOCK_ ... ... NET, SOCK_DGRAM, 0); 説明 これは RFC 768 で記述されている User Datagram Protocol の実装である。 UDP はコネクションレスの、信頼性の低いデータパケットサービスである。 パケットは到着前に並び替えられ ... 項目 ip (7), raw (7), socket (7), udplite (7) The kernel source file Documentation/networking/ip-sysctl.txt . RFC 768 : User Datagram Protocol RFC 1122 : ホストの必要条件 RFC 1191 : path MTU discovery の記述 この文書について この man ページは Linux man-pag ... ... cket(AF_INET, socket_type, protocol); Valid socket types include SOCK_STREAM to open a stream socket, SOCK_DGRAM to open a datagram socket, and SOCK_RAW to open a raw (7) socket to access the IP protocol directly. protocol is the IP protocol in the IP he ... r sent. Valid values for protocol include: • 0 and IPPROTO_TCP for tcp (7) stream sockets; • 0 and IPPROTO_UDP for udp (7) datagram sockets; • IPPROTO_SCTP for sctp (7) stream sockets; and • IPPROTO_UDPLITE for udplite (7) datagram sockets. For SOCK_RAW ... 外させるべきである。 To bootstrap the path MTU discovery process on unconnected sockets, it is possible to start with a big datagram size (headers up to 64 kilobytes long) and let it shrink by updates of the path MTU. path MTU の値をまず見積もってみるには ... 日本語の文書やマニュアルを配布している個人/プロジェクトへのリンクです。