JM プロジェクトは、主に Linux 関連のマニュアルページの日本語ページを翻訳・公開しています。
... パケットを待つために、 route (8) サービス ( services (5) を参照) 用の udp (4) ソケットの接続を待つ。 ホストがネットワーク間のルータである場合、 routed は、直接接続されている全てのホストとネットワークに、 ルーティングテーブルの複製を定期的に提供する。 rout ... わち、ホップカウントが無限大でない場合)。 パケットの送信元ホストが、 既存のルーティングテーブルのエントリにあるネットワーク間ルータと同じ場合。 つまり、到達先へのパケットをルーティングする ルータそのものから、更新された情報を受け取る場合。 ルーティングテー ... 。 そのエントリの失効が ローカルのインターネット上で通知されるのを保証するために、 削除は更に 60 秒後になる。 ネットワーク間ルータとして動作しているホストは、 直接接続された全てのホストやネットワークに対して、 30 秒毎に無条件でルーティングテーブルを提供す ... ... ng.isc.org" になります。 Figure 1 のように subnet に固有のパラメータを与えたいのは、 当然ながら、サブネットはそれぞれ違ったルータを必要とするからです。 したがって最初のサブネットには、 例えば以下のような文が置かれることになるでしょう。 option routers 20 ... 4.254.239.1; ここではアドレスは数値で指定されています。 これは必須ではありません。 もしルータの各インターフェースが別々のドメイン名を持っているなら、 そのインターフェースの指定には、数値でなくドメイン名を用いても全くか ... まいません。 しかしながら、多くの場合ルータの IP アドレスそれぞれには 一つの同じドメイン名がつけられているでしょうから、 ここでその名前を用いるのは適切ではないでしょう ... ... を実装している。 ip には RFC 1112 に準拠した level 2 マルチキャストの実装が含まれている。 またパケットフィルタ機能を含む IP ルーターも実装されている。 プログラミングインターフェースは BSD ソケットと互換である。 ソケットに関するより詳細な情報は socket (7) ... アウォールがローカル側のネットワークに唯一のリンクを持っている 場合や、透過プロクシの場合に限って有効にすべきである。 通常のルーターやホストでは決して使用することのないように。 さもないとフラグメントが別のリンクを経由して伝わる場合に、 通信のフラグメント ... れていないインターフェースが経路上に存在すると失敗してしまう。 Path MTU Discovery をグローバルに無効にするよりは、 壊れているルーターを直すほうが良い。 Path MTU Discovery を無効にするとネットワークのコストが 大きくなってしまうからである。 ip_nonlocal_bind ... ... oo Big" パケットをブロックしている犯罪的に頭のいかれた ISP やサーバーを乗り越えるために使用される。 Linux ファイアウォール/ルーターでは何も問題がないのに、 そこにぶら下がるマシンでは以下のように大きなパケットをやりとりできないというのが、 この問題の兆候 ... 使うと、 IPv4 の TTL ヘッダーフィールドを変更できる。 TTL フィールドにより、 TTL がなくなるまでに、パケットが何ホップ (何個のルータ) を通過できるかが決定される。 TTL フィールドを設定したり増やすのは、 危険性を非常にはらんでいる。 したがって、可能な限り避 ... ... トを秒で指定します。 option routers ip-address [ , ip-address ... ] ; routers オプションは、 クライアントのサブネット上にあるルータの IP アドレスのリストを指定します。 ルータは、優先されるものから順にリストしてください。 option time-servers ip-address [, ... は、クライアントが応答すべきであることを意味します。 option router-discovery flag ; 本オプションは、 RFC 1256 で定義されるルータ発見 (Router Discovery) 機構を使用して ルータを請求すべきかを指定します。 値 0 は、クライアントはルータ発見を実施すべきでない ... ことを意味します。 値 1 は、クライアントはルータ発見を実施すべきであることを意味します。 option router-solicitation-address ip-address ; 本オプションは、 クライアントのルー ... ... ト (RTO) からの 復旧性能を向上させたアルゴリズムである。 この機能は無線環境で特に効果を発揮する。 無線環境では、通常は、中間ルーターの輻輳ではなくランダムな無線の干渉 によりパケットロスが発生する。 詳細は RFC 4138 を参照。 このファイルは以下のいずれかの値 ... ... と。 ループバックインターフェースは自動的に設定される。 -seed を指定した場合、他の全てのフィールドが存在しなければならない。 ルータがこのシード情報を認めない場合、 atalkd はブートせずに終了する。 -seed が指定されない場合、他の全ての情報は自動設定で上書きさ ... ディレクティブは「デフォルト」ゾーンである。 フェーズ 1 では、1 つのゾーンしかない。 フェーズ 2 では、ネットワーク上の全てのルータは デフォルトゾーンに設定され、これを認めなければならない。 atalkd は、``*'' を第 1 インターフェースのデフォルトゾーンに対応 ... づける。 注意: マシンのデフォルトゾーンはローカルルータの設定によって決められる; デフォルトゾーンがない場合、 afpd のような各サービスは、個別に希望するゾーンを指定しなければならな ... ... オプションを使ってテストできる。 TTL の詳細 IP パケットの TTL という値は、パケットが破棄される前に通過することができる IP ルータの最大値を示す。 現在の慣例から、インターネットの各ルータは TTL フィールドを正確に 1 減らすことを期待できる。 TCP/IP 規格は、 ... oe リリース以前の BSD Unix システムが行っていたものである。 この場合、受け取ったパケットの TTL の値は、255 から往復経路上のルータの数を引いたものになる。 255 にセットする; これは現在の BSD Unix が行っているものである。 (訳注: Linux もこれにあたる)。 この ... 場合、受け取るパケットの TTL の値は、リモートシステム から ping を行ったホストへの経路上のルータの数を、255 から引いたものである。 その他の値にセットする。いくつかのマシンは、例えば 30 または 60 のような TCP パケットの値 ... ... ないデバイス NUD_PERMANENT 静的なエントリー 有効な ndm_flags は以下の通り: NTF_PROXY プロクシ arp エントリー NTF_ROUTER IPv6 ルータ rtattr 構造体は、 rta_type フィールドに応じてそれぞれ以下の意味を持つ: NDA_UNSPEC 未知のタイプ NDA_DST 近傍キャッシュネット ... ... ーの原因となったパケットを 受信したインターフェースのプライマリアドレスで送信される。 この動作は、多くのネットワーク管理者がルーターに対して期待しているものであり、 これにより複雑なネットワークレイアウトのデバッグがより容易になる。 選択されたインターフェ ... イマリアドレスが使用される点に 注意すること。 icmp_ignore_bogus_error_responses (ブール値; デフォルト: 無効; Linux 2.2 以降) ルーターの中には、RFC1122 に違反し、ブロードキャストフレームに対して 偽の応答を送信するものがある。 このような違反は通常カーネルの ... 装では、 IPPROTO_ICMP raw ソケットがサポートされていない。 この機能は移植性が必要なプログラムでは用いるべきでない。 Linux がルーターとして動作していないときには、 ICMP_REDIRECT パケットは送信されない。 またこれらが受け取られるのも、発信元がルーティングテ ... 日本語の文書やマニュアルを配布している個人/プロジェクトへのリンクです。