JM プロジェクトは、主に Linux 関連のマニュアルページの日本語ページを翻訳・公開しています。
... は RFC 791 と RFC 1122 で記述されている Internet Protocol, version 4 を実装している。 ip には RFC 1112 に準拠した level 2 マルチキャストの実装が含まれている。 またパケットフィルタ機能を含む IP ルーターも実装されている。 プログラミングインターフェースは BSD ソケ ... rectly with the name resolver (see gethostbyname (3)). IPv4 アドレスには、ユニキャストアドレス、 ブロードキャストアドレス、マルチキャストアドレスがある。 ユニキャストアドレスは、あるホストの一つのアドレスを指定する。 ブロードキャストアドレスは、あるネットワーク ... 上の全てのホストを指定する。 マルチキャストアドレスは、マルチキャストグループに所属する 全てのホストを指定する。ブロードキャストアドレスへのデータグラムは、 SO_BROADCA ... ... ーネル空間で netlink クライアントを記述する。 sockaddr_nl はユニキャスト (単一の接続先にだけ送られる) にもできるし、 netlink マルチキャストグループ ( nl_groups が 0 でない場合) にも送ることができる。 struct sockaddr_nl { sa_family_t nl_family; /* AF_NETLINK */ un ... signed short nl_pad; /* 0 である */ pid_t nl_pid; /* ポート ID */ __u32 nl_groups; /* マルチキャストグループマスク */ }; nl_pid は netlink ソケットのユニキャストアドレスである。 行き先がカーネルの場合は、常に 0 である。 ユー ... 割り当てる。 nl_groups はビットマスクで、すべてのビットが netlink グループ番号を表す。 それぞれの netlink ファミリーは 32 のマルチキャストグループのセットを持つ。 それぞれの netlink ファミリーは 32 のマルチキャストグループの セットを持つ。 bind (2) がソケットに対 ... ... て 1 の両方のブロードキャスト形式に対応し、さらにサブネットマスクにも対応している。 ether multicast パケットがイーサネットのマルチキャストであるとき真。 ether はなくて もよい。これは ` ether[0] & 1 != 0 'の省略記法である。 ip multicast パケットが IP のマルチキャ ... ストであるとき真。 ip6 multicast パケットが IPv6 マルチキャストパケットであるとき真。 ether proto protocol パケットが ether の protocol 型のものであるとき真。 protocol には番号か ip 、 ip ... あるとみなす。長さ演算子はキーワード len で示され、パケット長を与える。 たとえば、` ether[0] & 1 != 0 'という条件式はすべてのマルチキャスト による通信をとらえる。` ip[0] & 0xf != 5 ' という条件式はすべてのオ プション付きの IP パケットをとらえる。` ip[6:2] & 0x1f ... ... ない。 IFF_PROMISC インターフェースは promiscuous モードである。 IFF_NOTRAILERS trailer の利用を避ける。 IFF_ALLMULTI 全てのマルチキャストパケットを受信する。 IFF_MASTER 負荷分散グループのマスターである。 IFF_SLAVE 負荷分散グループのスレーブである。 IFF_MULTICAS ... T マルチキャストをサポートしている。 IFF_PORTSEL ifmap によってメディアタイプを選択できる。 IFF_AUTOMEDIA 自動メディア選択が有効になっている ... ort; }; ifmap 構造体の解釈はデバイスドライバとアーキテクチャーに依存する。 SIOCADDMULTI , SIOCDELMULTI デバイスのリンク層のマルチキャストフィルターから、 ifr_hwaddr のアドレスを追加・削除する。これらの操作には特権が必要である。 別の方法が packet (7) で解説されて ... ... を有効/無効にする。 もし有効にすると、ネットワーク上のすべてのパケットは このインタフェースにより受信される。 [-]allmulti 全マルチキャスト (all-multicast) モードを有効/無効にする。 もし有効にすると、ネットワーク上のすべてのマルチキャスト・パケットは このインタフ ... ドウェアクラスは ether (イーサネット), ax25 (AMPR AX.25), ARCnet , netrom (AMPR NET/ROM) である。 multicast インタフェースのマルチキャストフラグを設定する。 通常はドライバーが自動で設定するので、 address このインタフェースに割り当てる IP アドレス。 txqueuelen le ... ... Broadcast =ff:ff:ff:ff:ff:ff/ff:ff:ff:ff:ff:ff, BGA =01:80:c2:00:00:00/ff:ff:ff:ff:ff:ff である。ブロードキャストアドレスはマルチキャストアドレスにも マッチングする点に注意すること。 --src はこのオプションのエイリアスである。 -d, --destination [!] address [/ ma ... ドによって決まる。取りうる値は、 broadcast (送信先 MAC アドレスがブロードキャストアドレス), multicast (送信先 MAC アドレスがマルチキャストアドレス), host (送信先 MAC アドレスが受信ネットワークデバイス), otehrhost (それ以外) のいずれかである。 stp stp BPDU (bridg ... す。 これは通常 logging バックエンド nfnetlink_log との組み合わせで使用され、 これが netlink ソケット経由でパケットを指定したマルチキャストグループにマルチキャストする。 1 つあるいは複数のユーザスペースプロセスがそのグループに参加してパケット を受け取ることができ ... ... g のソース、ならびに FreeBSD の man ページを参考に 日本語訳に際して追加された。 -I interface 与えられたインタフェースから、マルチキャストパケットを送る。 -L マルチキャストパケットのループバックを抑制する。 -t ttl マルチキャストパケットの IP 寿命時間 (Time To Li ... ... (ブロードキャストとして送信される) RTN_ANYCAST ローカルなブロードキャスト経路 (ユニキャストとして送信される) RTN_MULTICAST マルチキャスト経路 RTN_BLACKHOLE パケットを捨てる経路 RTN_UNREACHABLE 到達できない行き先 RTN_PROHIBIT パケットを拒否する経路 RTN_THROW 経路 ... ... 指定して setsockopt (2) を呼び出すことで設定できる。 PACKET_ADD_MEMBERSHIP PACKET_DROP_MEMBERSHIP packet ソケットは、物理層のマルチキャストや 無差別モード (promiscuous mode) を設定して使うことができる。 PACKET_ADD_MEMBERSHIP はバインドを追加し、 PACKET_DROP_MEMBE ... モード (promiscuous mode)" と呼ばれる)。 PACKET_MR_MULTICAST は、そのソケットを、 mr_address と mr_alen で指定される物理層のマルチキャストブループにバインドする。 PACKET_MR_ALLMULTI は socket を up にして、そのインターフェースに到達したすべての マルチキャストパケ ... に渡すときに 起きたエラーしか処理しない。遅延エラー (pending error) に関する概念は持っていない。 エラー EADDRNOTAVAIL 不明なマルチキャストグループアドレスが渡された。 EFAULT ユーザーが渡したメモリーアドレスが不正。 EINVAL 引数が不正。 EMSGSIZE パケットがインター ... ... ST ユニキャストアドレス LOCAL ローカルアドレス BROADCAST ブロードキャストアドレス ANYCAST エニーキャストアドレス MULTICAST マルチキャストアドレス BLACKHOLE ブラックホールアドレス UNREACHABLE 到達できないアドレス PROHIBIT 禁止されたアドレス THROW 要修正 NAT 要修 ... urceip-sourceport-destport のいずれかでなければならない。 --clustermac mac ClusterIP の MAC アドレスを指定する。 リンク層のマルチキャストアドレスでなければならない。 --total-nodes num このクラスターの総ノード数。 --local-node num このクラスターのローカルノード番 ... og をロギングバックエンドとして使う組み合わせで使用される。 nfnetlink_log はそのパケットを netlink ソケット経由で指定されたマルチキャストグループにマルチキャストする。 1 つ以上のユーザー空間プロセスがマルチキャストグループを購読しパケットを受信することができる。 ... 日本語の文書やマニュアルを配布している個人/プロジェクトへのリンクです。