JM Project

JM プロジェクトは、主に Linux 関連のマニュアルページの日本語ページを翻訳・公開しています。

Linux マニュアル 一覧

全文・高度検索

per page, with , order by , clip by
Results of 1 - 10 of about 179 for マルチ (0.008 sec.)
Man page of MBLEN 11866
MBLEN Section: Linux Programmer's Manual (3) Updated: 2015-08-08 Index JM Home Page 名前 mblen - 次のマルチバイト文字のバイト数を返す 書式 #include < stdlib.h > int mblen(const char * s , size_t n ); 説明 s が NULL でなければ、 mblen () 関数 ... は s から始まる最大 n バイトのマルチバイト文字列を検査して、 次の完全なマルチバイト文字を取り出す。これには mblen () 関数のみが使用する静的で名前のないシフト状態 ... が使用される。 マルチバイト文字がヌルワイド文字でなければ s から消費される バイト数を返す。マルチバイト文字がヌルワイド文字ならば 0 を返す。 s か ... ら始まる n バイトが完全なマルチバイト文字を含んで いなければ、 mblen () は -1 を返す。マルチバイト文字列 に冗長なシフトシーケンスが含まれていると、 n が MB ...
https://man.mtool.work/man/20260915/man3/mblen.3.html
Man page of MBRLEN 11222
MBRLEN Section: Linux Programmer's Manual (3) Updated: 2015-08-08 Index JM Home Page 名前 mbrlen - 次のマルチバイト文字の長さをバイト数で返す 書式 #include < wchar.h > size_t mbrlen(const char * s , size_t n , mbstate_t * ps ); 説明 mbrlen ... () 関数は s から始まるマルチバイト文字列を 最大 n バイト調べて次の完全なマルチバイト文字を取り出す。 同時にシフト状態 *ps を更新する。 マルチバイト文字が ... するバイト数を返す。ナルワイド文字ならばシフト状態 *ps を 初期状態に戻して、0 を返す。 s から始まる n バイトの文字列が完全なマルチバイト文字を含んで いない場合には mbrlen () は (size_t) -2 を返す。 マルチバイト文字列に冗長なシフトシーケンスを含まれている ... と n >= MB_CUR_MAX の時にもこのようなことが起こりえる。 s から始まるマルチバイト文字列が、次の完全な文字の前に 不正なマルチバイト列を含んでいる場合には、 mbrlen () は (size_t) -1 を返し errno に EIL ...
https://man.mtool.work/man/20260915/man3/mbrlen.3.html
Man page of MBRTOWC 10211
MBRTOWC Section: Linux Programmer's Manual (3) Updated: 2019-03-06 Index JM Home Page 名前 mbrtowc - マルチバイト列をワイド文字に変換する 書式 #include < wchar.h > size_t mbrtowc(wchar_t * pwc , const char * s , size_t n , mbstate_t * ps ); ... 関数が用いられる場合、通常 s が NULL でなく pwc も NULL で ない。この場合は、 mbrtowc () 関数は s から始まる最大 n バイトの マルチバイト文字を検査して、次の完全なマルチバイト文字列を取り出し、 それをワイド文字に変換して *pwc に格納する。 同時にシフト状態 ... ト数を返す。 変換したワイド文字が L'\0' の場合にはシフト状態 *ps を 初期状態に戻して 0 を返す。 s から始まる n バイトが完全なマルチバイト文字を含んでいない 場合には、 mbrtowc () は (size_t) -2 を返す。 マルチバイト文字列に冗長なシフトシーケンスが含まれてい ... ると、 n >= MB_CUR_MAX の時にもこのようなことが起こりえる。 s から始まるマルチバイト文字列が、次の完全な文字の前に 不正なマルチバイト列を含んでいる場合には、 mbrtowc () は (size_t) -1 を返し、 errno に ...
https://man.mtool.work/man/20260915/man3/mbrtowc.3.html
Man page of MBSRTOWCS 8977
MBSRTOWCS Section: Linux Programmer's Manual (3) Updated: 2019-03-06 Index JM Home Page 名前 mbsrtowcs - マルチバイト文字列をワイド文字列に変換する 書式 #include < wchar.h > size_t mbsrtowcs(wchar_t * dest , const char ** src , size_t len , ... mbstate_t * ps ); 説明 dest が NULL でなければ、 mbsrtowcs () 関数は マルチバイト文字列 *src を dest から始まるワイド文字列に 変換する。 dest には最大で len 文字のワイド文字が 書き込まれる。同時にシフ ... dest が 1 増加させられ、 *src が消費したバイト数だけ増加させられる。変換は以下の三つの いずれかの条件で停止する: 1. 不正なマルチバイト列に遭遇した。この場合には *src は不正な マルチバイト列を指すようにして、 (size_t) -1 を返し、 errno に EILSEQ を設定す ... る。 2. len 文字の L'\0' 以外のワイド文字を dest に格納した場合。 この場合は *src は次に変換されるマルチバイト列を指すようにして、 dest に書き込まれたワイド文字の数を返す。 3. マルチバイト文字列が終端のヌルワイド文字 ('\0') まで ...
https://man.mtool.work/man/20260915/man3/mbsrtowcs.3.html
Man page of ICONV 8622
ICONV Section: Linux Programmer's Manual (3) Updated: 2017-09-15 Index JM Home Page 名前 iconv - 文字セット変換を行う 書式 #include < iconv.h > size_t iconv(iconv_t cd , char ** inbuf , size_t * inbytesleft , char ** outbuf , size_t * outby ... のは、 「 inbuf が NULL でなく、かつ *inbuf が NULL でない」 という場合である。 この場合、 iconv () 関数は、 *inbuf で始まるマルチバイト文字列を *outbuf で始まるマルチバイト文字列に変換する。 *inbuf を先頭として最大 *inbytesleft バイトが読み込まれ、 *out ... buf を先頭として最大 *outbytesleft バイトが書き出される。 iconv () 関数は 1 度に 1 つのマルチバイト文字を変換する。 そして、各文字変換毎に、変換された入力バイトの数だけ *inbuf を増加させ、 *inbytesleft を減少させる。 ... 換にも対応しており、 バイト出力を伴わずに変換状態を更新することができる。 変換は、次の 4 つの場合に停止する。 1. 入力に無効なマルチバイト文字列があった場合。この場合、 関数は errno を EILSEQ に設定し、 (size_t) -1 を返す。 *inbuf は、無効なマルチバイト文字 ...
https://man.mtool.work/man/20260915/man3/iconv.3.html
Man page of MBSNRTOWCS 8622
MBSNRTOWCS Section: Linux Programmer's Manual (3) Updated: 2020-06-09 Index JM Home Page 名前 mbsnrtowcs - マルチバイト文字列をワイド文字列に変換する 書式 #include < wchar.h > size_t mbsnrtowcs(wchar_t * dest , const char ** src , size_t nm ... が *src から始まる最大 nms バイトに制限されている点が異なっている。 dest が NULL でなければ mbsnrtowcs () 関数は *src からのマルチバイト文字列の最大 nms までを dest からのワイド文字列に変換する。 最大 len 文字のワイド文字が dest に書き込まれる。 同時にシ ... dest が 1 増加させられ、 *src が消費したバイト数だけ増加させられる。変換は以下の三つの いずれかの条件で停止する: 1. 不正なマルチバイト列に遭遇した。この場合には *src は不正な マルチバイト列を指すようにして、 (size_t) -1 を返し、 errno に EILSEQ を設定す ... 制限によって強制的に停止するか、 len 文字の L'\0' 以外の ワイド文字を dest に格納した場合。この場合は *src は 次に変換されるマルチバイト列を指すようにして、 dest に書き込まれた ワイド文字の数を返す。 3. マルチバイト文字列が終端のヌルワイド文字 ('\0') まで ...
https://man.mtool.work/man/20260915/man3/mbsnrtowcs.3.html
Man page of MBTOWC 8622
MBTOWC Section: Linux Programmer's Manual (3) Updated: 2019-03-06 Index JM Home Page 名前 mbtowc - マルチバイト列をワイド文字に変換する 書式 #include < stdlib.h > int mbtowc(wchar_t * pwc , const char * s , size_t n ); 説明 この関数が用いら ... れる場合、通常 s が NULL でなく pwc も NULL でない。この場合は mbtowc () 関数は s から始まる 最大 n バイトのマルチバイト文字列を検査して、次の完全なマルチバイト 文字を取り出し、それをワイド文字に変換して *pwc に格納する。 同時に mbtowc 関 ... 指している場合は、 s から消費するバイト数を返す。 s がヌルバイトを指している場合には 0 を返す。 s から始まる n バイトが完全なマルチバイト文字を含んで いない場合や不正なマルチバイト列を含んでいる場合には mbtowc () は -1 を返す。マルチバイト文字列に冗長なシ ... 準拠 POSIX.1-2001, POSIX.1-2008, C99. 注意 mbtowc () の動作は現在のロケールの LC_CTYPE カテゴリーに依存している。 この関数はマルチスレッドでは安全ではない。 mbrtowc (3) 関数は 同じ機能のより良いインターフェースを提供する。 関連項目 MB_CUR_MAX (3), mblen ...
https://man.mtool.work/man/20260915/man3/mbtowc.3.html
Man page of NETLINK 8399
NETLINK Section: Linux Programmer's Manual (7) Updated: 2020-06-09 Index JM Home Page 名前 netlink - カーネルとユーザー空間の通信 (AF_NETLINK) 書式 #include < asm/types.h > #include < sys/socket.h > #include < linux/netlink.h > netlink_sock ... まれる。 バイトストリームには、標準の NLMSG_* マクロによってのみアクセスすべきである。 より詳しい情報は netlink (3) を見よ。 マルチパートメッセージ (一つ以上の nlmsghdr ヘッダーと、それに対応するペイロードが 一つバイトストリームに含まれる) においては、 先 ... メッセージは無視される。 NLMSG_ERROR メッセージはエラーを示し、ペイロードには nlmsgerr 構造体が入る。 NLMSG_DONE メッセージはマルチパートメッセージの終了を伝える。 struct nlmsgerr { int error; /* 負または 0 の errno は応答を表す */ struct nlmsghdr msg; /* ... nlmsg_flags の標準フラグビット NLM_F_REQUEST 要求メッセージ全てでセットされなければならない。 NLM_F_MULTI このメッセージはマルチパートメッセージの一部である。 マルチパートメッセージは NLMSG_DONE で終端する。 NLM_F_ACK 成功した場合の応答を要求する。 NLM ...
https://man.mtool.work/man/20260915/man7/netlink.7.html
Man page of IP 8333
IP Section: Linux Programmer's Manual (7) Updated: 2020-11-01 Index JM Home Page 名前 ip - Linux IPv4 プロトコルの実装 書式 #include < sys/socket.h > #include < netinet/in.h > #include < netinet/ip.h > /* 上記のスーパーセット */ tcp_socket ... は RFC 791 と RFC 1122 で記述されている Internet Protocol, version 4 を実装している。 ip には RFC 1112 に準拠した level 2 マルチキャストの実装が含まれている。 またパケットフィルタ機能を含む IP ルーターも実装されている。 プログラミングインターフェースは ... rectly with the name resolver (see gethostbyname (3)). IPv4 アドレスには、ユニキャストアドレス、 ブロードキャストアドレス、マルチキャストアドレスがある。 ユニキャストアドレスは、あるホストの一つのアドレスを指定する。 ブロードキャストアドレスは、あるネッ ... トワーク上の全てのホストを指定する。 マルチキャストアドレスは、マルチキャストグループに所属する 全てのホストを指定する。ブロードキャストアドレスへのデータグラムは、 SO ...
https://man.mtool.work/man/20260915/man7/ip.7.html
Man page of fetchmail 7755
fetchmail Section: User Commands (1) Index JM Home Page 名前 fetchmail - POP, IMAP, ETRN, ODMR 機能を持つサーバからメールを取得する 書式 fetchmail [ option... ] [ mailserver... ] fetchmailconf 説明 fetchmail はメールを取得・転送するためのユ ... fetchmail を設定する場合には、 初心者モード (Novice mode) を使うことをお勧めします。 上級者モード (Expert mode) を使うと、 マルチドロップ機能を含む fetchmail の設定を完全に制御することができます。 どちらの場合でも、`Autoprobe (自動検出)' ボタンを押すと、 ... 出力に書き込まれます。 fetchmail が付け直した MAIL FROM と RCPT TO 行が正しいことの 保証はない点に注意してください。 後述の「マルチドロップメールボックスの利用と不正使用」の 議論における注意事項が適用されます。 リソースの制限・制御のためのオプション -l <最 ... 変更します。 通常これは `X-Envelope-To' ですが、これは標準ヘッダではないので、 実際には別のものになることがあります。 後述のマルチドロップアドレス処理に関する議論を参照してください。 特殊な場合として、`envelope "Received"' を設定すると sendmail 形式の Re ...
https://man.mtool.work/man/20260915/man1/fetchmail.1.html
PREV 1 2 3 4 5 6 7 8 9 10 NEXT

リンク

日本語の文書やマニュアルを配布している個人/プロジェクトへのリンクです。