JM プロジェクトは、主に Linux 関連のマニュアルページの日本語ページを翻訳・公開しています。
... nsquery プログラムは、BIND リゾルバのライブラリ呼び出しによって ネームサーバとやりとりする一般的なインタフェースです。 本プログラムはオペコード QUERY によるネームサーバ問い合わせを サポートしてい ... して作成されました。 host と nameserver 以外の引数は大文字小文字を区別しません。 オプション -n nameserver 問い合わせに用いるネームサーバ。 ネームサーバ指定は、w.x.y.z 形式のインターネットアドレス表記でも、 ドメインネーム表記でも構いません。 (デフォルト: ... /etc/resolv.conf の指定。) -t type 関心あるリソースレコード型。型には以下のものがあります: A アドレス NS ネームサーバ CNAME 正式名 PTR ドメインネームへのポインタ SOA 権威の開始 (Start of Authority) WKS よく知られたサービス (well-known ... ... を行います。 nslookup には対話モードと非対話モードの 2 つのモードがあります。 対話モードでは、 様々なホストやドメインの情報をネームサーバに対して問い合わせたり、 あるドメイン内のホスト一覧を表示することができます。 非対話モードでは、あるホストもしくはドメ ... 名前および 要求した情報のみが表示されます。 引数 次の場合は対話モードに入ります。 a) 引数が与えられなかったとき(デフォルトのネームサーバを利用します)。 b) 最初の引数がハイフン (-) であり、2 番目の引数がネームサーバの ホスト名もしくは IP アドレスであるとき ... いホストの名前もしくは IP アドレスが最初の引数として与えられた場合は、 非対話モードになります。 2 番目の引数はオプションで、ネームサーバのホスト名もしくは IP アドレスを 指定します。 `` set '' コマンドを使うオプションは、ホームディレクトリの .nslookuprc フ ... ... )に代わって snaplen バイトをおのおののパケットから取り出し利用する。 IP, ICMP, TCP, UDP については 68 バイトあれば十分だが、ネームサーバや NFS の情報には足りないかもしれない(後述)。 snapshot 制限のために後ろが切り捨てられたパケットは出力時に``[| proto ]' ... 形式になっているものとみなす。 ] decnet src host DECNET においてソースアドレスが``10.123''のようなアドレスや DECNETのホ ストネームの形式で指示される host と一致するとき真。[DECNETのホストネーム形式は DECNETに接続された ultrix システムにおいてのみ利用可能 ... ソースまたはディスネーション のポート番号より)解釈することができ、より上位の層におけるプロトコル 情報を表示する。特にドメインネームサービス要求(RFC-1034/1035)や NFS についての Sun RPC (RFC-1050)について出力される。 UDP ネームサービス要求 (注:以下は RFC-10 ... ... - S ] nameserver [ [ axfr ] | [ ixfr ] 解説 named-xfer は、 named (8) によって実行される補助プログラムです。 インターネットネームサーバから呼び出されて、ゾーン情報を受け取ります。 直接実行されることはまれであり、ゾーン転送の問題を解決するために システム ... 管理者にいよってのみ実行されることがある程度です。 インターネットネームドメインシステムについての詳細は、 RFC 1033 、1034 、1035 を参照してください。 オプションとしては、以下のものがあります: -z ... ます。 -t trace_file ゾーン情報転送のプロトコルトレースを格納するトレースファイル trace_file を指定します。 このオプションはネームサーバそのものをデバッグする人にとってのみ 有益なのかもしれません。 -p port# デフォルト以外のポート番号を使用するときに指定し ... ... Internet ドメインネームサーバを更新する ためのプログラムです。 nsupdate は DNS のリソースレコード (RR) を追加したり削除したりする メッセージを DNS ... フィールドで定義されるマスタサーバへ送られます。 空行は、蓄積されたレコードを 1 個の更新要求としてまとめ、ゾーンの権威を もつネームサーバへの送信を指示します。 追加レコードを続けることが可能です。 これらは、追加的な、完全に独立した更新要求になります。 最後 ... 。 $ nsupdate -k /var/named/keys:mykey > update add ftp.example.com 60 A 192.168.5.1 > 診断 Qq send error 一般に、権威のあるネームサーバに到達できなかったことを示します。 Qq failed update packet 一般に、ネームサーバが動的更新をサポートしていないためか、認 ... ... データーベースから、ひとつ以上のキーとその値とを表示する。 mapname にはマップ名またはマップのニックネームを指定できる。 オプション -d domain domainname (1) が返すデフォルトのドメイン以外を指定する。 -k マップのキーを表示する。この ... オプションは値が null のマップや、 キーが値の一部となっていないマップに対して便利である。 -t マップのニックネーム変換を抑制する。 -x マップのニックネームの変換テーブルを表示する。 ファイル /var/yp/nicknames マップのニックネームの変換テー ... ... domain name determined from the hostname. この状態を変更するための設定オプションには、以下のようなものがある。 nameserver ネームサーバの IP アドレス レゾルバが問い合わせをするネームサーバのインターネットアドレス。 アドレスには IPv4 アドレスか IPv6 アド ... そらくドット表記も可) で指定する。 このキーワード 1 つごとに 1 台づつ、 MAXNS 台 (現状では 3 台、 < resolv.h > を参照) までのネームサーバをリストできる。 複数のサーバが指定された場合、レゾルバライブラリは リストされた順に問い合わせを行う。 nameserver エン ... トリーがない場合、 デフォルトではローカルマシン上のネームサーバが使われる。 (ここで使われるアルゴリズムは以下のようなものである。 はじめにネームサーバに問い合わせを試みる。 この問い ... ... domain name determined from the hostname. この状態を変更するための設定オプションには、以下のようなものがある。 nameserver ネームサーバの IP アドレス レゾルバが問い合わせをするネームサーバのインターネットアドレス。 アドレスには IPv4 アドレスか IPv6 アド ... そらくドット表記も可) で指定する。 このキーワード 1 つごとに 1 台づつ、 MAXNS 台 (現状では 3 台、 < resolv.h > を参照) までのネームサーバをリストできる。 複数のサーバが指定された場合、レゾルバライブラリは リストされた順に問い合わせを行う。 nameserver エン ... トリーがない場合、 デフォルトではローカルマシン上のネームサーバが使われる。 (ここで使われるアルゴリズムは以下のようなものである。 はじめにネームサーバに問い合わせを試みる。 この問い ... ... NIS データーベースから、すべてのキーとその値とを表示する。 mapname にはマップ名またはマップのニックネームを指定できる。 オプション -d domain domainname (1) が返すデフォルトのドメイン以外を指定する。 -h hostname ypbind (8) によって ... ーを表示する。このオプションは値が null のマップや、 キーが値の一部となっていないマップに対して便利である。 -t マップのニックネーム変換を抑制する。 -x マップのニックネームの変換テーブルを表示する。 ファイル /var/yp/nicknames マップのニックネームの変換テー ... ... る事により、システム管理者はネームサーバを制御可能です。 command を指定しないと、 ndc は、EOF を読み込むまでの間コマンド入力を促します。 オプションは次の通りで ... のアドレス以外からの接続を拒否するように、サーバを設定可能です。 書式は channel のものと同じです (上述参照)。 -p pidfile 古いネームサーバとの後方互換性のため、制御通信用に ndc は UNIX シグナルを使用可能です。 この機能は現在のネームサーバではオプションであ ... テムのトレースを有効にします。 インストール時のデバッグに有用です。 コマンド いくつかのコマンドは ndc に組み込まれています。 ネームサーバがサポートする完全なコマンドセットは動的であり、これは help コマンド (後述参照) で確認できるはずです。 組み込みコマンド ... 日本語の文書やマニュアルを配布している個人/プロジェクトへのリンクです。