JM Project

JM プロジェクトは、主に Linux 関連のマニュアルページの日本語ページを翻訳・公開しています。

Linux マニュアル 一覧

全文・高度検索

per page, with , order by , clip by
Results of 1 - 10 of about 74 for データグラム (0.007 sec.)
Man page of RECV 11439
RECV Section: Linux Programmer's Manual (2) Updated: 2020-11-01 Index JM Home Page 名前 recv, recvfrom, recvmsg - ソケットからメッセージを受け取る 書式 #include < sys/types.h > #include < sys/socket.h > ssize_t recv(int sockfd , void * buf ... のこと。 エラーの原因となったオリジナルパケットのペイロードは、 msg_iovec 経由で通常のデータとして渡される。 エラーを起こしたデータグラムのオリジナルの宛先アドレスは、 msg_name 経由で参照できる。 このエラーは sock_extended_err 構造体で提供される: #define SO_EE_ ... inux 2.4.27/2.6.8 以降)、 netlink (Linux 2.6.22 以降) ソケット、 UNIX datagram ソケット (Linux 3.4 以降) の場合、パケットやデータグラムの長さが渡したバッファーよりも長かった場合にも、 パケットやデータグラムの実際の長さを返す。 Internet ストリームソケットでの利 ... ) を示し、 返されたデータが完全なレコードであることを示す (一般的には SOCK_SEQPACKET 型のソケットで使用される)。 MSG_TRUNC データグラムが与えられたバッファーより大きかったために、 データグラムのはみ出した部分が捨てられたことを示す。 MSG_CTRUNC 補助データのため ...
https://man.mtool.work/man/20260915/man2/recv.2.html
Man page of RECV 11439
RECV Section: Linux Programmer's Manual (2) Updated: 2020-11-01 Index JM Home Page 名前 recv, recvfrom, recvmsg - ソケットからメッセージを受け取る 書式 #include < sys/types.h > #include < sys/socket.h > ssize_t recv(int sockfd , void * buf ... のこと。 エラーの原因となったオリジナルパケットのペイロードは、 msg_iovec 経由で通常のデータとして渡される。 エラーを起こしたデータグラムのオリジナルの宛先アドレスは、 msg_name 経由で参照できる。 このエラーは sock_extended_err 構造体で提供される: #define SO_EE_ ... inux 2.4.27/2.6.8 以降)、 netlink (Linux 2.6.22 以降) ソケット、 UNIX datagram ソケット (Linux 3.4 以降) の場合、パケットやデータグラムの長さが渡したバッファーよりも長かった場合にも、 パケットやデータグラムの実際の長さを返す。 Internet ストリームソケットでの利 ... ) を示し、 返されたデータが完全なレコードであることを示す (一般的には SOCK_SEQPACKET 型のソケットで使用される)。 MSG_TRUNC データグラムが与えられたバッファーより大きかったために、 データグラムのはみ出した部分が捨てられたことを示す。 MSG_CTRUNC 補助データのため ...
https://man.mtool.work/man/20260915/man2/recvfrom.2.html
Man page of RECV 11439
RECV Section: Linux Programmer's Manual (2) Updated: 2020-11-01 Index JM Home Page 名前 recv, recvfrom, recvmsg - ソケットからメッセージを受け取る 書式 #include < sys/types.h > #include < sys/socket.h > ssize_t recv(int sockfd , void * buf ... のこと。 エラーの原因となったオリジナルパケットのペイロードは、 msg_iovec 経由で通常のデータとして渡される。 エラーを起こしたデータグラムのオリジナルの宛先アドレスは、 msg_name 経由で参照できる。 このエラーは sock_extended_err 構造体で提供される: #define SO_EE_ ... inux 2.4.27/2.6.8 以降)、 netlink (Linux 2.6.22 以降) ソケット、 UNIX datagram ソケット (Linux 3.4 以降) の場合、パケットやデータグラムの長さが渡したバッファーよりも長かった場合にも、 パケットやデータグラムの実際の長さを返す。 Internet ストリームソケットでの利 ... ) を示し、 返されたデータが完全なレコードであることを示す (一般的には SOCK_SEQPACKET 型のソケットで使用される)。 MSG_TRUNC データグラムが与えられたバッファーより大きかったために、 データグラムのはみ出した部分が捨てられたことを示す。 MSG_CTRUNC 補助データのため ...
https://man.mtool.work/man/20260915/man2/recvmsg.2.html
Man page of UDP 9836
UDP Section: Linux Programmer's Manual (7) Updated: 2020-04-11 Index JM Home Page 名前 udp - IPv4 の ユーザーデータグラムプロトコル 書式 #include < sys/socket.h > #include < netinet/in.h > #include < netinet/udp.h > udp_socket = socket(AF_I ... き、 ローカルアドレスやリモートアドレスは指定されない。 正しい行き先アドレスを引数として sendto (2) や sendmsg (2) を呼べば、データグラムはただちに送信される。 ソケットに対して connect (2) を呼ぶと、デフォルトの行き先アドレスが設定され、 send (2) や write (2) を ... 使って、行き先アドレスの指定なしにデータグラムを送信できるようになる。 この場合でも、行き先アドレスを sendto (2) や sendmsg (2) に渡せば、デフォルト以外のアドレスに送信可 ... sockets, see socket (7). UDP_CORK (Linux 2.5.44 以降) このオプションが指定されると、このソケットの全てのデータ出力は 一つのデータグラムに蓄積され、このオプションが無効化された時に 送信される。 このオプションは移植性を考慮したコードでは用いるべきではない。 ioc ...
https://man.mtool.work/man/20260915/man7/udp.7.html
Man page of SOCKET 9446
SOCKET Section: Linux Programmer's Manual (2) Updated: 2020-06-09 Index JM Home Page 名前 socket - 通信のための端点 (endpoint) を作成する 書式 #include < sys/types.h > /* 「注意」参照 */ #include < sys/socket.h > int socket(int domain , int ... 続された バイトストリーム (byte stream) を提供する。 帯域外 (out-of-band) データ転送メカニズムもサポートされる。 SOCK_DGRAM データグラム (コネクションレス、信頼性無し、固定最大長メッセージ) をサポートする。 SOCK_SEQPACKET 固定最大長のデータグラム転送パスに基づ ... 取ることが要求される。 SOCK_RAW 生のネットワークプロトコルへのアクセスを提供する。 SOCK_RDM 信頼性はあるが、順序は保証しないデータグラム層を提供する。 SOCK_PACKET 廃止されており新しいプログラムで使用してはいけない。 packet (7) を参照すること ある種のソケット型 ... いは read (2) コールが要求された量のデータのみを返し、到着したパケットの残りの部分を 捨ててしまうことである。同様に入ってくるデータグラムの全てのメッセージ境界は 保存される。 SOCK_DGRAM と SOCK_RAW ソケットは sendto (2) コールで指定された相手へデータグラムを送る ...
https://man.mtool.work/man/20260915/man2/socket.2.html
Man page of TCPDUMP 8986
TCPDUMP Section: User Commands (1) Updated: 30 June 1997 Index JM Home Page 名前 tcpdump - ネットワークのトラフィックをダンプする 書式 tcpdump [ -adeflnNOpqRStvxX ] [ -c count ] [ -F file ] [ -i interface ] [ -m module ] [ -r file ] [ -s sn ... != 5 ' という条件式はすべてのオ プション付きの IP パケットをとらえる。` ip[6:2] & 0x1fff = 0 'はフラ グメント化されていないデータグラムか 0 番の(最初の)フラグメントだけを表示する。 なお、この条件は tcp と udp への適用を暗示している。さら に tcp[0] は TCP ヘッ ... ケット長からなるフレーム制御フィールドを表示する。(フレーム制御フィールドはパケットの残りの部分の解釈 の制御をおこなう)。(IP データグラムを含むような)通常のパケットは優先度 0 から 7 を持つ`async' パケットである;たとえば ` async 4 '。この ようなパケットは 802.2 ... LLC を含むとみなされる。LLCヘッダはそれが ISO データグラムやいわゆる SNAP パケット でない ならば、表示される。 (注:以下の記述は RFC-1144 による SLIP 圧縮アルゴリズムを理解しているもの ...
https://man.mtool.work/man/20260915/man1/tcpdump.1.html
Man page of UDPLITE 8917
UDPLITE Section: Linux Programmer's Manual (7) Updated: 2017-09-15 Index JM Home Page 名前 udplite - 軽量なユーザーデータグラムプロトコル 書式 #include < sys/socket.h > sockfd = socket(AF_INET, SOCK_DGRAM, IPPROTO_UDPLITE); 説明 これは RFC ... 3828 に書かれている軽量なユーザーデータグラムプロトコル (Lightweight User Datagram Protocol; UDP-Lite) の実装である。 UDP-Lite は UDP (RFC 768) の拡張で、可変長のチェック ... サムをサポートしている。 このプロトコルが効果を発揮するのは、少しだけ壊れたデータグラムがあった場合に、 そのデータグラムを下位レイヤーのプロトコルに廃棄させるのではなく、 それを利用することができるような、ある種 ... は送信側のチェックサムの対象範囲を設定する。 int 型を引数として取り、設定可能な値の範囲は 0 から 2^16-1 までである。 値 0 はデータグラム全体が常にチェックサムの対象となることを意味する。 値 1〜7 は不正であり (RFC 3828 の 3.1 章)、範囲の設定として最小値である 8 ...
https://man.mtool.work/man/20260915/man7/udplite.7.html
Man page of IP 8819
IP Section: Linux Programmer's Manual (7) Updated: 2020-11-01 Index JM Home Page 名前 ip - Linux IPv4 プロトコルの実装 書式 #include < sys/socket.h > #include < netinet/in.h > #include < netinet/ip.h > /* 上記のスーパーセット */ tcp_socket ... を指定する。 マルチキャストアドレスは、マルチキャストグループに所属する 全てのホストを指定する。ブロードキャストアドレスへのデータグラムは、 SO_BROADCAST ソケットフラグがセットされていないと送信・受信できない。 現在の実装では、接続指向のソケットにはユニキャスト ... サイズの塊に分割したり、必要に応じて再送したりするのは、 ユーザーが責任を持って行う必要がある。 既知の Path MTU よりも大きなデータグラムの送信が要求されると、 カーネルは ( EMSGSIZE で) 送信を拒否する。 IP_PMTUDISC_WANT の場合は、 Path MTU に基づいて必要であれば ... とができる ( IP_RECVERR を見よ)。 MTU 更新が到着するごとに、新たなエラーがキューイング される。 MTU discovery の進行中には、データグラムソケットからの初期パケットは 到着しないかもしれない。 UDP を用いるアプリケーションでは、 このことを気にかけておき、 パケット ...
https://man.mtool.work/man/20260915/man7/ip.7.html
Man page of SEND 8722
SEND Section: Linux Programmer's Manual (2) Updated: 2020-11-01 Index JM Home Page 名前 send, sendto, sendmsg - ソケットへメッセージを送る 書式 #include < sys/types.h > #include < sys/socket.h > ssize_t send(int sockfd , const void * buf , ... である。 Linux 2.6 以降では、このフラグは UDP ソケットでもサポートされており、 このフラグ付きで送信された全てのデータを一つのデータグラムにまとめて 送信することを、カーネルに知らせる。まとめられたデータグラムは、 このフラグを指定せずにこのシステムコールが実行さ ... ontrollen; /* 補助データバッファー長 */ int msg_flags; /* フラグ (未使用) */ }; フィールド msg_name は、 未接続のソケットでデータグラムの宛先アドレスを指定するのに使用される。 このフィールドはアドレスを格納したバッファーを指す。 フィールド msg_namelen にはアド ... めていない。 したがって、移植性が必要なアプリケーションでは、両方の可能性を 確認すべきである。 EAGAIN (インターネットドメインデータグラムソケットの場合) sockfd が参照するソケットがそれ以前にアドレスにバインドされておらず、 そのソケットに一時ポートをバインドしよ ...
https://man.mtool.work/man/20260915/man2/send.2.html
Man page of SEND 8722
SEND Section: Linux Programmer's Manual (2) Updated: 2020-11-01 Index JM Home Page 名前 send, sendto, sendmsg - ソケットへメッセージを送る 書式 #include < sys/types.h > #include < sys/socket.h > ssize_t send(int sockfd , const void * buf , ... である。 Linux 2.6 以降では、このフラグは UDP ソケットでもサポートされており、 このフラグ付きで送信された全てのデータを一つのデータグラムにまとめて 送信することを、カーネルに知らせる。まとめられたデータグラムは、 このフラグを指定せずにこのシステムコールが実行さ ... ontrollen; /* 補助データバッファー長 */ int msg_flags; /* フラグ (未使用) */ }; フィールド msg_name は、 未接続のソケットでデータグラムの宛先アドレスを指定するのに使用される。 このフィールドはアドレスを格納したバッファーを指す。 フィールド msg_namelen にはアド ... めていない。 したがって、移植性が必要なアプリケーションでは、両方の可能性を 確認すべきである。 EAGAIN (インターネットドメインデータグラムソケットの場合) sockfd が参照するソケットがそれ以前にアドレスにバインドされておらず、 そのソケットに一時ポートをバインドしよ ...
https://man.mtool.work/man/20260915/man2/sendmsg.2.html
PREV 1 2 3 4 5 6 7 8 NEXT

リンク

日本語の文書やマニュアルを配布している個人/プロジェクトへのリンクです。